OSMC wireless and wired not workin

I think it has a very strange problem. I installed osmc in a Blacberry Pi 2 a few days days. I tried to conected throught wired and wireless and both ways it worked perfect.
A few hours ago, i was playing music from my computer to the OSMC using airplay and suddenly it stop working. I restarted the Blackberry but it can’t conected anymore. In the wired, it says: "Status: eth0 (No internet). I tried wireless and it was also impossible.
I reinstalled osmc again from the begining but still without working.
I thought it was the router, so i try to connect to my iphone-wifi but it was impossible. i can choose the network, but in a second the wireless goes automatically to disable.
I try to look for something similar in the forums but i didn’t find anything helpful.
Many thanks in advance!!

Exactly what is a Blackberry Pi?

Hahahaa… Raspberry Pi!! :wink:

Did you try rebooting the router?

Yes, several times and the router looks that works fine since I have internet in my laptop and in my iphone. Any idea. I was thinking in installing another operative system to check if it can be a hardware malfunction.

Provide logs if you’d like to pursue this further. There is no reason why it should work without issue one moment and not the next.

I’m Trying to upload logs but since i don’t have internet conection i can’t… Can i do it in another way?

Can you try using either the wifi or the LAN one at the time, as in ONLY one connected to the device?

I tried both in different reboots but any of them worked. It’s very strange because i just try to install NOOBS and it can’t get conected to internet nether… :frowning:

Hi! Now it’s working! The problem had nothing to do with the raspberry or OSMC. The ethernet was conected with homeplugs and one of them crashed. I changed it and now it’s working again. Thanks Action A for your time.

good day too i can’t connect to the internet it writes me: “eth0 no internet” please help. how did you get an error?

This (very old) thread was about wireless. I suggest you open a new thread and provide logs.

1 Like