OSMC with berryboot or virtual machine

I want to test OSMC but I don’t have a spare SD card.

So I tried to install OSMC through adding a custom OS on Berryboot. I ran into an error message, something like “fstab not installed”. I think this happens if the OS is not Debian based (enough).

Is it possible to install OSMC as a virtual machine in VirtualBox? I tried unsuccessfully.

OSMC is based on Debian

Emulating VideoCore and Pi specifically under VirtualBox won’t work well. We will have x64 images within the month and these should work on VirtualBox (but obviously VirtualBox isn’t a target of ours so you will have to wait). We are working on getting NOOBS support for OSMC. This may be the best way to keep multiple Pi distributions on the same SD card.


So why does it not work with Berry Boot?

No idea

I’m pretty sure BerryBoot needs a squashFS based filesystem.

You’re right it does.

I followed the tutorial on the BerryBoot website and converted the OSMC image to a squashFS type, I got the ‘fstab’ error message when booting OSMC.


Just checking:

you did this after running the installer right? The installer extracts the real filesystem and creates stuff fstab on the fly.


To my knowledge, I grabbed the .img file from one of the alpha builds in the archived forum. I didn’t run any installer.

The image is an installer. You need to let that complete, then take an image of your SD card and run BerryBoot’s tools on that.

This is why you are getting the error. You are running the BerryBoot tools on the unconfigured image