OSMC with KODI Krypton?

My OSMC is not brought in by the mediacenter-osmc package, so this version doesn’t give insight. If I remember correctly, you had your Pi offline for some time, so it may not be fully up to date. You should check the actual OSMC version rather than the Kodi deb version.

I found out how to obtain the OSMC version from the command line (I have to use PuTTY to do this stuff):

grep VERSION_ID /etc/os-release VERSION_ID="2016.06-2"
In the meantime I also found how to set the target directory for backups in MyOSMC, so I have run it to save my config.
Additionally I have googled for a way to back up the OSMC Kodi configuration and on this page I got the advice to copy out the ~/.kodi directory, so I did this in PuTTY:

cp -R .kodi/* /media/MEDIADRIVE/backup-osmc/.kodi

Now I have a copy of the .kodi dir plus a tar file from the built-in backup on my MEDIADRIVE disk (a 1TB NTFS formatted USB disk).
If I now go ahead and execute the commands to get the testing version of Kodi:

sudo apt-get update sudo apt-get install rbp2-mediacenter-osmc
will I afterwards be able to get back to my old release OSMC if the testing version does not work properly for me?
I cannot image the complete SD-card because I don’t have a micro-SDcard reader available in my current location…

PS: I do not know from where the strange formatting of my code sections above comes, I only pasted pure text strings from PuTTY into the code sections when composing this message. DS

I went ahead and edited the /etc/apt/sources.list according to the instructions for getting the testing version. But before running the install I wanted to make sure I was on the latest OSMC release (mine was from June) so I made a dist-upgrade.
I screwed up apparently because now MyOSMC has disappeared and Kodi system info says I have Kodi 17 beta1
Is there a way to get back the MyOSMC program add-on?

It was disabled. :frowning:
But when I enabled it and then went to use it all that showed up was the center circle with the zener diode symbol. Seems like it is now broken.
It means that there is now no place to do OSMC specific operations (like restoring the backup I did earlier from the MyOSMC add-on).

I don’t use v17 so can not comment on that.

I am wondering what you wanted to restore from the backup? Switching to v17 would not have deleted anything from your osmc directory that you would be able to recover from the backup.

You need to enable all parts of MyOSMC, for example Network Manager, Apps etc.
Then you will see more then center circle.

I had the same issue when I installed Krypton.

1 Like

I ended up reverting to the release version…

  • remove the gmc source from /etc/apt/sources.list
  • sudo apt-get update
  • sudo apt-get install rbp2-mediacenter-osmc=16.1.0-16
  • reboot

Now I am back at the Kodi version 16.
The test with 17 in order to get sound on sports in the ViaPlay add-on did not work.

It is unlikely that Krypton will solve this without additional work. The author notes:

However, with Krypton and its new input stream add-ons, a fix is hopefully just around the corner.

Any clue on how to do this, I don’t see any of those entries in the Kodi addon Browser?

@mcaron1234 I don’t remember the exact steps and I my Kodi 17 install is currently at my summer house so I cant check for you.

The aption to activate is somewhere within the addon browser where you list all installed addons. There you should be able to find them and activate.

Try going to addons/addon browser/my addons/all and check that My OSMC and all the the parts are enabled.

I was able to find all the parts in the section of the addon browser for dependencies. Enabling all the items related to MyOSMC there, got everything working in the addon, with the exception of the backup app. I was unable to find anything to enable to get backup working.

Would a log be helpful to you with this issue?

Hej Bosse_B!

Jag köpte nyss en Raspberry pi 3 och laddade ner Viaplay addon men kan inte logga in. vet du hur jag ska göra?

Please use english, I’ve sent you a pm with swedish instructions on how i got the addon to work.

I thought that you sent me a private message so I responded to that instead of here in the thread…
This was my response:
Inställningar -> KODI -> Tillägg -> Mina tillägg -> Videotillägg -> VIAPLAY -> Inställningar
(I do not know what an English version of Kodi would name these selections)
Then add email and password for the Viaplay account you use.

PS: I am still waiting for OSMC to upgrade to KODI 17 in the hope that sound will be present on sports items. DS

Running the latest krypton RC that Sam released and i have sound in Viaplay addon

Thank you for the inf!

I just installed the beta [TESTING] Kodi 17 (Krypton) Beta Builds for all platforms and it works great, with sound and all!

Is there any timeline as to the release of OSMC+Krypton?
I noted that the post linked to above was from Oct 16, 2016, so maybe now there is more info on the closeness to a release?

Krypton was officially released just a few days ago. It will take OSMC team of developers some time to “OSMC-ing” it to the standard we are used to, with ease of install etc.