OSMC won't boot when HDMI is connected

I am running OSMC on raspi 2. When the hdmi cable is connected to a tontec 7" TFT LCD monitor (1024*600), the pi freezes on boot up.

Now when I disconnect the hdmi cable (& re-plug power adapter 5.0v at 2.0A) the pi boots up fine, I can then connect hdmi (but no hdmi signal will display on the monitor after initial boot) & reboot via ssh and all is well. I know I can force_hotplug the hdmi instead of reboot however, this doesn’t alleviate the initial freeze upon boot up that I will have every time I power down and turn on the pi.

My use is for a “carputer” without access to the hdmi cable (from the outside of dash anyway).

I noticed that if I completely disconnect the monitors power, let the pi boot up with hdmi connected, then connect power to the monitor, then I can re-boot or turn on hdmi_force_hotplug this will work too. (the above situation still occurs even when the monitors power button is off but still has power connected to monitor)

So my solution (for now) is to run a switch in the monitors power line. Boot up OSMC with hot_plug enabled then connect power to the monitor (via switch) and then turn on the power button to the monitor.

I think somehow current is sinking or is back-feeding through the hdmi cable? causing power disruptions upon boot up, which in turn leads to the no boot.

Any advice or better solutions are much appreciated.

Then try a better quality cable?

Better quality HDMI cable?

I’ve tried 3 different cables I have at the house with the same results.

GE VW-1 high speed
Radio Shack high performance triple shielded
Copartner VW-1 1.4

I’ll look on the wiki to find one that is spec’d

I’d suspect a power supply/grounding issue.
If you don’t fully connect the hdmi at one end, but just hold the metal of the hdmi plug to the metal of the socket does it still fail to boot? That would confirm it’s the ground and not the data from hdmi causing the issue.

I have the hdmi plugged into the monitor (powered on), then held the metal of plug to metal of socket on the pi;
it boots up

But you say it doesn’t if hdmi cable is plugged in?

Are you sure Pi fails to boot, and hasn’t booted but negotiated an unsupported hdmi mode?

Can you try ssh-ing in?

That is correct, not if hdmi is plugged in upon initialization.
I’m not able to ssh when this happens and red led stays lit

I just connected everything the same with raspi model B and it booted up as should.

Guess this is issue with the pi 2 or this individual unit?

In some rare cases the power lines of the hdmi cable can have a too high or low voltage which leads to problems. Can you test if the pi boots when connected to a different screen?

Yes, pi 2 boots when connected to my other screen that has composite video.

Do you know the normal voltage ranges hdmi, so I can check with digital multi-meter?

I meant another hdmi screen.

Have a look at the hdmi specification and check the 5V of your screen.

Just wanted to say this project is really turning out well (osmc carputer)!

I’ll look into my tontec monitor’s voltage later today and report back.

I briefly galnced at OSMC’s - hardware - hdmi settings and plan to look into it further.

Also, Thank You to everyone who replied.

The pi-2 boots up just fine when I connected it to my flat screen (via hdmi);
guess it’s an anomaly with the tontec controller board and pi-2.

Both the tontec & flat screen measured the same voltage when taken between pins 18 & 17 (-3.3V)
The hdmi cable was plugged in to the monitor/tv only (not the pi) & measured from the opposite end of the cable.

The 5V comes from the source (Pi) not the sink (display). Measuring the voltage when fully connected and running would be more interesting.

May be worth storing the edid to a file ( http://kodi.wiki/view/Raspberry_Pi_FAQ#TV_is_not_detected_unless_powered_on_first ).