OSMC won't play videos since update

Since updating OSMC on a Vero 4K videos won’t play from my NAS. The files are in .ts format stored on a FreeNAS server. The files play fine on anything else so I know it is not a problem with the files or the FreeNAS box. Before the update they played fine on the Vero.

The Vero 4K will happily play videos using add-ons such as Cnet.

The .ts files attempt to play but stutter and then grind to a holt. It is as if there is a major buffering issue.

I know people will want to see the log files but I don’t know where to find them or how to attach them to this post.

Can someone also answer a basic question about Putty? When I log into the box some directories are easy to read but others I find impossible to read. I know I can change the colours in Putty but what is the colour for the directories that are not highlighted? I’ve tried changing them but can’t seem to find the right one.

grab-logs -A and paste the resultant URL here.

Thank you. Things are easy if you just know how… shame I don’t!!

The url is


He’ll want to enable debug logging first, surely?

@DLD-UK , the usual way to grab a log file is:

  • Go into Settings / System / Logging and enable debug logging.

  • Reboot twice.

  • Reproduce the issue.

  • Go into My OSMC (which is now under Settings) and select the clipboard icon (“log uploader”).

  • Make sure “all configs and logs” is checked and then select Upload Selected Logs Now.

  • When it finishes uploading it will give you a web address which starts with https://paste.osmc.tv/ - copy the address into a post here and the OSMC guys can read the logs from that web page.

  • Turn off debug logging when you’re done.

If things lock up so badly that you can’t get into My OSMC, then doing grab-logs -A from the command line is another way to upload them.

Posting MediaInfo for one of the problem files is sometimes helpful too.

1 Like

I love your login name. There was a company called Livid Lobster which I thought really good.

Will do what you say when I’ve woken up enough.

I think I had been travelling on a London Underground train the day I chose that! :laughing:

London Underground in rush hour is a nightmare!

I think I followed the instructions and the new log is


After the reboot all I did was try to play the video and it stuttered and locked up.

Finally managed to sort this out. I powered everything down and powered it back up. Made no difference. Replaced the Vero downstairs with another one. Made no difference.

In desperation I pulled the mains plug out of the socket and waited a couple of minutes. Plugged everything back in and it worked. I didn’t think that still made a difference these days.

The strange thing is that all Internet video worked the whole way through. It was just videos stored on the FreeNAS box that would not play. I didn’t unplug the FreeNAS box.

I’d love to know what people think was the cause of it?