OSMC's April update is here with Kodi 16.1

Our new April update to OSMC lands nice and early this month, hot off the heels of the Kodi 16.1 release. We like to keep on top of Kodi releases, and make sure that users are always running the latest stable version. We delivered Kodi Jarvis (16.0) just

This is a companion discussion topic for the original entry at https://osmc.tv/2016/04/osmcs-april-update-is-here-with-kodi-16-1/

I have got a sad face after updating even after rebooting. i have a raspberry pi 2 btw

The release thread here in the news subforum is NOT for support requests. Start a appropriately titled thread in the appropriate Help and Support subforum for assistance.

Fantastic update & Great work!

Pi B+ - No issues. My Wife’s show that has always displayed as pixelated now looks buttery smooth. Snappier interface too.

Pi 2 - No issues, same result at B+

Vero 1 - Required a hard boot after install (just displayed a black screen). Ok now. Still looking forward to DVD.ISO menu support here :wink:

Vero 2 - Took about a dozen times to get to update from 2.4 sans a lockup,

  • No more lockups with default user interface!
  • CEC is MUCH improved!
  • Restoring Customized UI mapping required a hard boot after the restore from backup (Vero1 used to create master backup)
    -DVD.ISO with menus. Some work (but a bit slow to start) while others still fail to start.
    -Still getting some weird random audio pops

Thanks for this update! It fixed all my frustrations with the raspberry pi 3!
Had to reboot a couple of times after the update but I am very happy :smiley:


Just installed on 1 pi, hopefully fixes the random freezing issues as well as the xhoppy video caused my the gpio entry in config.txt

Is it OK that Kodi tells from itself on the Systeminfo its Version 16.1 RC3 ?


I was to consider that OSMC only used finals from Kodi. It’s fine anyway.

It’s final in my eyes. See Commits · xbmc/xbmc · GitHub. Not many changes over the last two weeks, and mainly for other platforms. I don’t anticipate any issues, and we have made sure to get the latest fixes from @popcornmix. Should anything arise, we will push any fixes as soon as they are available.

updated today, videos are all showing a black screen now, audio works, video stays black

Not a support request, but a warning.

If you are not requesting support, then it would seem advising how you resolved the issue might be more helpful? Though, one report out of literally thousands of installs is more likely an individual config problem than an issue with the update.

You’ve provided exactly zero info that could be used to debug an issue. You haven’t even declared what device you are using or anything else. In the future, it would be great if you’d not try to suggest to the entire user base that one user’s issue (which could be caused by any of thousands of reasons) should be expected for all users. No use in fear mongering here.

Was just a warning so users may delay the update for a day or two, fixed the problem meanwhile, and it was not on my end, but with the update process.
Just fyi i am running stock osmc with zero changes on a rpi 2, so the chances it is due to a user error, as you suggested is nill.
In the Future i will refrain from coming here and possibly reporting anz bug or issue since your unfriendly and aggressive reaction to a report of caution (without any complaints or anything else of that sort) tells me everything i need to know.

Have a nice day.

This is the part that would be quite interesting to know and might even make this exchange worth something to someone… If you really wished to help, one would think you might volunteer the info…

In case it matters, I had a similar problem updating today. The screen was black while playing videos. Subtitles showed and sound was playing. Looked around in settings and saw that “Allow hardware acceleration - OMXPlayer” was disabled. Enabled it and everything now all works ok. I am not sure how the settings were prior to the update, but everything worked normally.

1 Like

Thanks for providing useful info patrik!

Raspberry pi 1. Kodi does not start up after april update. Pi works, just not kodi.
Startup manually: mediacenter start works but,
root@mrt:~# mediacenter start
Starting Kodi…
mv: failed to preserve ownership for ‘/boot/config.txt’: Operation not permitted
mv: failed to preserve ownership for ‘/boot/config.txt’: Operation not permitted

2016-04-03 18:53:28.947140 apt_cache_action.py running
2016-04-03 18:53:28.949514 apt_cache_action.py sending response
2016-04-03 18:53:28.953313 apt_cache_action.py sending response
Pulse ===========================================

Started update manually again results in “Update error” message.

Anything to do with:
"The Raspbian mirror director is currently experiencing an issue which may affect updates for Raspberry Pi 1 and Raspberry Pi Zero. The maintainer has been made aware of the problem and hopefully this will be resolved soon. Other OSMC devices are not impacted by this.

Thank you for your patience"

Yes – that’s why there’s a big banner on the forum.

We can’t do anything our side to resolve this and must simply wait for the mirror to be brought back online again.