OSMC's August update is here

Hi Sam,

Seems my remote now does not work after the August update? I have seen this happen and have posted about it here before:

Have tried the power cycle and it doesn’t see the remote still,

Will I just rebuild OSMC again?

Which remote do you have? I haven’t changed eventlircd or LIRC at all in this update, so double check your configuration in My OSMC -> Remotes.

Edit: I see you’re referring to CEC (detail is important ;)). I haven’t updated libCEC either, so you probably just need to power down your TV for a while and other equipment. For some devices, this is the only way to resolve CEC problems.

Its a Sony remote for its 48 inch Bravia 48W705c TV

OK I will try that

:disappointed: Another month waiting time for Kodi 17 since it’s in beta currently.

Sounds great. Is there a thread explaining how to switch to a test build and especially how to revert back?
I’m always afraid of switching to a test build 'cause I fear it could break something or I can’t revert back to stable build.

Did you search?

If you are worried about this, you should just wait for the stable version. There are a fair few changes so it won’t be trivial to downgrade

Actually yes, I did. I have a vero2. Is it the same command to install a test build?

  • I can’t find info to downdrade to stable if I want to.
    But yeah, as sam sated I guess I’ll just wait.

Downgrade info is covered a few times in that post, but I can’t guarantee a smooth downgrade, as a lot of other packages will change too. It’s not a scenario that we claim to support.

That post is for Pi builds only.

If you clone your SD card you can use a spare sd card to test Krypton.

Vero2 has a internal storage and can’t boot osmc from sd card…as far as i know.

HI Daverbelo, hope you are well.

I have exactly the same issue - very distressing as I am not that tech savy. Can you tell me please how you solved this issue and got your Kodi working on OSMC with the latest update.

Best regards

Gazza

Just update again, it means your device was on the devel repo before

1 Like

Thanks!! all done and works well. Regards Gazza

Everything going smooth here. Only two tiny exceptions were the (now almost traditional) sad face / error screen after the first boot past update installation, and a reset of CEC settings, but I guess that’s due to changes in the CEC modules/code. Good job, guys! :slight_smile:

CEC wasn’t touched in this update.

We do know about the sad face post update though. @DBMandrake and I have discussed it in the past. It’s caused by script.skinshortcuts. Eventually, we’ll fix it.

Oh, okay. Just thought so because of

Added support for CEC builtins to Kodi so that add-ons can use and query CEC capabilities
Add support to configure repeat button settings via CEC on Vero 2


No problem, really minor issue.

That was a change to Kodi, not libCEC itself. It won’t changed previous behaviour.

We’ll crush it in the near future, it will be killed by My OSMC 2.

Can you please link to the git changes regarding the kodi memory leak?

Is this the same changes popcornmix fixed recently when browsing the library?

I installed this update a few days ago (10-ish, don’t know the exact date), and ever since I installed it I’ve started noticing some issues on video playback on my rpi3.

What I’m noticing is that the video will sometimes show white ‘dots’ in some (apparently random) parts of the image, the position of which change on each frame. More annoyingly to me, the sound will occasionally get jerky (as in, no sound will play for maybe 1 second or less). It feels like these issues get worse and happen more often the longer the video is (to the point that watching a long 2h video has some seriously annoying sound issues towards the end), so it sounds like it could be some sort of leak to me.

As I said I started noticing this after installing this update, but that does not necessarily mean it was introduced here, I might simply have not noticed it before (been using this box for 4-5 weeks). Is there any info I can provide to help debug this?

Thanks!