OSMC's January update is here - OSMC

Hi, when will the January disk images be available for download from the website? Thanks!

They will be ready later today in a couple of hours.

I recorgnized that cpu load is always about 70-100% while watching a full hd movie since the January update.

It is running smooth all the time but i still wonder why this is now.

Does this got recorgnized by anyone else?

Please start a forum post with debug logs so we can look in to any issues you have. The announcement thread isn’t for troubleshooting.

It will be useful if you can screenshot top output on the system before the update and after.

I just had another update (second January update). What did the update address?

Reverted the “Allow Resolution Downgrade” patch that caused issues for certain people.

Got an update error (for the second January update), here are my logs: http://paste.osmc.io/orodozuyod

I’m on 2018.01-01. Trying to manually scan for an update now leads to an addon error.
These are the logs right after the error: http://paste.osmc.io/zovaximewa

Some exceptions being thrown it seems :frowning:

Edit: After a restart the manual update scan works again and reports no updates. So it seems the update worked despite those errors.

Thanks for the update, still have a possible OSMC default skin error for the Weather where the weather is shifted by a day between the weather menu view and full screen view. Have posted a couple of pi screen images (look at Wednesday on the menu screen & Thu on the full screen!

Please start a forum post so we can look in to this further.

Hi Sam, I did about 8 months ago, also updated it today. Titled “Weather shifted by a day” Original post had no response I recall



Here’s the link!



Finally my tv auto switchs 3D mode now! Great update!

1 Like

Huh? Did I miss something? :astonished:

well until this update, in every 3d movie had to go to my remote and change my tv to 3d, now it’s automatic.

That’s nice… Didn’t see anything in the changelog, that’s why I’m asking. :wink:

Maybe some update component fixed that.

There was a fix for permissions on sysfs that now resolved auto switching in Kodi.


1 Like

Fix an issue which would prevent some services which use DRM (i.e. Netflix, Amazon Prime Video) from working correctly in Raspberry Pi

So does that mean I can somehow watch Netflix on OSMC?
I tried multiple solutions during past years and months and nothing worked.
Is there some app or something now?

Yes, you would need to install Kodi Leia from the testing stream and then you can use Netflix after installing the . Use the search function and search Leia and Netflix