OSMC's January update is here!

You know nothing John Snow

Any changes related to LIRCd? My remote control stop working on RPI2…
edit: running lircd alone and trying irw, doesn’t show anything ;(

I have just updated my Apple TV that was reinstalled from scratch and now I have an image of Apple TV with question mark blinking above it and yellow light blinking on Apple TV box and I can’t connect to it via SSH. What should I do?

First of all, thanks for your efforts and for bringing this kodi amazing experience to all of us!!!

I have an issue starting from the last update (and in this one is happening again). If I update (in Kodi, as you recommend), my HDMI-CEC driver is not working anymore. Last time, I managed to get it work again, but I don’t remmember what I did. I don’t know whether I’m the only one having this issue, but can you please have a look at this? Do you have any suggestions?

Once again, thanks for your great efforts! :slightly_smiling:

@Beam, @Lamoboy, @rjuarezp and anyone else.
Please don’t post any issues in the news thread.
Open a new thread explaining your issues and provide respective logs. Please see How to submit a useful support request - General - OSMC for advice on how to help us.

Ok. Sorry! I will follow up the issue and report if I cannot get it work again! Of course, if I get the solution, I will post it as well. Just want to make sure that it is not an issue from my TV! :slightly_smiling:


For CEC problems the best is always to first power-off and disconnect OSMC and TV for a couple of minutes and then restart

It works!!! :slight_smile: Thanks a lot!!!

After this last update my HiFi berry stoped to work.
In Pi settings I have same settings like before but in audio output ALSA is only bc2835 and I cant change it to anything else.

Does anybody else expirienced problem like this?

1 Like


Thank you very much for quick reply


After this update, my RC6 MCE Remote is working oddly. First it received the first 3 keypresses and then stopped working for like 1 minute, and then started receiving keypresses again (red dot in receiver was blinking, so signals were being received). But now, MCE remote is not working at all. Receiver is working also. Tried switching USB ports but nothing. I saw in the changelog that there was a fix for duplicate keypresses which is good, but this problem came now. Could it be related?

Any ideas?
Thank you all!!

Have a quick search, sounds like your remote was relying on the internal decoder


Hello Sam! Thank you for your fast answer!

I found several threads regarding this issue, along with a very interesting discussion, hehe. I’m glad that OSMC team addresses issues every month, and as it was said, if it benefited the majority of users, then kudos!

So I think I followed the steps necessary for my fix, I commented out the 2 lines inside the blacklist file in “/etc/modprobe.d/blacklist-rc6.conf”. But I am not getting my remote back. Tried switching profiles in My OSMC from lircd-full to rc6-lirc with no luck. The ir_rc6_decoder is showing up now in lsmod.

Am I missing something?
Is it now using the internal decoder or is there another step necessary?

Thanks and sorry for the inconvenience.

If the module is showing, the internal decoder is operational and in use. We would need to see further logs to work out what is up

If further support is required on this matter, please open an appropriately titled thread. Release announcement posts are not intended as support threads. Thanks!

I can just say “oh my god”. I can’t believe my problem was related to the batteries of the remote!!! The IR receiver was receiving signals because I was getting the red led light blink. But it appears that if the batteries are not strong enough the signal isn’t as well, it gets picked up but does not get through, very odd.

Please excuse the inconvenience.
BTW the fix of the new update seems to be working fine.

Thanks to all!!!

i don’t see the update

You need to start a proper forum post with logs.

how can i make this?