OSMC's June update is here with Kodi v18.7 - OSMC

You can either use the Keymap Editor add-on or else at the end of the guide that Sam linked to their is a keymap examples that shows the code to manually make that particular change.

Thanks! I’ll give it a shot.

Hi!

After the June update it seems that docker daemon is no longer working :frowning:
I’ve tried install docker again but apt-get failed with broken dependencies

You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
libasound2 : Depends: libasound2-data (>= 1.1.8-1+rpt1) but 1.1.3-5 is to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

I’ve also get this libasound2-data dependencies as a popup message in OSMC after the updgrade.

Here what journalctl -xe returns:

Jun 05 21:30:00 osmc systemd[1]: docker.service: Start request repeated too quickly.
Jun 05 21:30:00 osmc systemd[1]: docker.service: Failed with result 'exit-code'.
-- Subject: Unit failed
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- The unit docker.service has entered the 'failed' state with result 'exit-code'.
Jun 05 21:30:00 osmc systemd[1]: Failed to start Docker Application Container Engine.
-- Subject: A start job for unit docker.service has failed
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- A start job for unit docker.service has finished with a failure.
--
-- The job identifier is 940 and the job result is failed.
Jun 05 21:30:00 osmc systemd[1]: docker.socket: Failed with result 'service-start-limit-hit'.
-- Subject: Unit failed
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- The unit docker.socket has entered the 'failed' state with result 'service-start-limit-hit'.

Thanks for your help!
Maty.

Your filesystem looks severely corrupted. I would suggest starting a new post with full logs.

1 Like

I have been using the testing release (by adding the videoimprovevero repo to my apt sources.list) for a while to great effect with flawless frame-packed 3D which has been working great. I did just update to the June release (after it was offered). I notice frame-packed 3D is now playing back in 2D.

I checked the testing thread and there was a comment made that updating to Kodi 18.7 would mean we would “lose 3D”.

When will it be back again, and is there a trivial way to get it back manually without a reinstall? I am au-fait with removing/installing/holding/unholding packages and adding/removing repos etc in Debian…

Please try:

sudo apt-get install --reinstall vero3-mediacenter-osmc=18.6.0-13

Sam

1 Like

Hello
I tried to play a sacd iso file , it could open music files in dsd format only through file manager not through music screening , and while opening music files it just a tone not music , what could be the cause?
Thanks

Hi,

Please open a new topic with logs.

Thanks Tom.

Lovely job. Perfect!
Thanks, Sam.

Although this would probably be best done with a new topic as Tom asked my guess is that you may be trying to play multichannel files which is not currently supported and cause just a noise to be made (from what I read skimming the last few pages of this). As for it only working in file manager that is expected Kodi behavior until you tell it an iso can be an audio file by editing an advancedsettings.xml file adding in…

<musicextensions>
	<add>.iso</add>
</musicextensions>

I just tried it and that change allowed file manager to use paplayer, it to be browsable in music, and I was able to successfully scan an album into my music library. It also plays fine, although this is likely because it is only stereo.

I tried this and it said

osmc@osmc:~$ sudo apt-get install --reinstall vero3-mediacenter-osmc=18.6.0-13
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Version ‘18.6.0-13’ for ‘vero3-mediacenter-osmc’ was not found

Anyway to fix this?

The reason I want to restore the previous version is that after I installed 18.7 today on my Vero, all of my movies stopped playing. When I try to play them, the screen might go on for a few seconds, then it fails and goes back to the main menu. Some change happened that broke my ability to play any movies. Some video content still works, seems like if I were to guess stuff with low bitrate. But my Blu Rays that I have rips of or have made MKVs out of, nope.

Are you using Kodi SMB mounts to access your Movies?
If yes check this thread

If you are not sure provide log files so that we can check.

You are a mensch! Thank you so much for being helpful, I was able to follow that thread, which I missed when I scanned the forums, apply the fix to my NAS and everything is working again. Thanks again and have a great night.

1 Like

Glad to hear that’s helped. I should have a fix for SMBv2 tomorrow.

The command you ran failed because it’s specifically for 4.9 testers

Sam

Hi, I have installed the June update on my three Raspberry Pi3. Unfortunately the fast forward and rewind with picture does not work anymore. is there a solution here? Best regards, Ernest

I can’t think of any changes that would cause this in this update, but fast forward and rewind aren’t really supported by Kodi.

If you would like assistance with this please start a new thread with some additional information such as what remote your using and what action did the keys used to perform. If you can post the keymap as well this would be helpful.

OSMC’s June update doesn’t work on RPi 3B+. I tried to install the update but after the installation OSMC doesn’t start, on the screen there is :-(, the same issue I had with OSMC’s March update.

Now I’m coping the imagine that I saved before to start the update, I hope well.

We haven’t had other reports of this. I suggest starting a new forum post with logs so we can get this resolved.

Great. Thank you.
The Kodi people also seem to have fixed a big which caused a crash everytime I tried to scan a flac file. Keep safe.