OSMC's March update is here with Kodi v18.6 - OSMC

I am not seeing any updates, yet.

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Usually takes about an hour for the mirrors to sync.

And it did, and it works!

Thanks @sam_nazarko!!!

Thanks for confirming.

Since the update Info and CodecInfo on the remote are not working anymore. Do I have to reconfigure the keymap for the remote?

Did you read the link that this original post points to and find this?

1 Like

My Vero is set to manual updates, nothing available according to the GUI next morning after the announcement of an update was made.

That second update was only for the Vero2. Do you have a Vero2?

1 Like

Apologies, did not catch that. I’ve posted elsewhere about the March update rendering my main Vero unusable due to constant blank screen issues, in lieu of an update I’m going to have to drop down to the Jan build.

Sorry if this is a stupid question but I am incredibly behind on the latest: I recently aquired a Pi4 but I am now starting to realize OSMC does not fully support it yet. Though, after this update, is it working to any extent at all (with a Pi 3+ image) or is it completely not working at all yet?

Thanks :slight_smile:

You can’t use an image for a RPi 3 to boot a RPi 4. The work on OSMC RPi 4 support has not advanced enough yet to make test builds available. If you want to to run Kodi on that hardware right now you will have to use Raspbian or LibreElec.

Unfortunately as you have downgraded it will be hard to work out the root cause of the issue you have experienced.

well, downgrading has proved it’s the March build that’s the issue, so that’s something at least.

1 Like

Okay! Noted. Thanks for the update. I do have a Pi 3 with OSMC rn. Guess I will just wait :slight_smile:

Works great. Thanks Sam

Thanks for the hard work, it works like a charm on my Vero4k+.

On my Vero 4k, after I installed the March update the random teaser film icons on the Kodi main screen (which used to be displayed when the movies menu was activated in the sidebar) have gone. Same for the TV series. I don’t know how to get them back.

I read about the remote long-press support in the newest update (2020.03-1) and went to install it, which it did just fine without errors. Am I missing something very obvious as none of the long-press actions seem to work ([HowTo] OSMC Remote - Long-Press Keymap Guide), do I need to do something to activate the new system?

Also when I got the Vero 4K+ couple of weeks ago the volume buttons have never worked, when I press the volume down button I get a “Volume 100%” on the screen, pressing volume up doesn’t show anything. Don’t know if that has anything to do with this, as didn’t really need volume control as I use my TV remote for that.

Any ideas?

Here are my logs: http://paste.osmc.tv/olehupikob

That sounds like you have passthrough enabled.

That long-press information is only applicable to the OSMC remote which I don’t see as being plugged in according to your log.

Regarding the Volume you only get volume control when using passthrough by using CEC. If your TV has CEC (BRAVIA sync) make sure it is turned on in your TV’s settings as well as in Kodi (settings>system>input>peripherals). If you don’t have working CEC on your TV you will have to disable passthrough to control volume through Kodi.