OSMC's March update is here with Kodi v18.6 - OSMC

Firstly, and most importantly, we hope that everyone and their loved ones are staying safe. We continue to work on and develop OSMC during this time and offer support and our store also remains open with orders being fulfilled promptly and without delay.

This is a companion discussion topic for the original entry at https://osmc.tv/2020/03/osmcs-march-update-is-here-with-kodi-v18-6/

This update didnt work for me.
After initiating it my Vero4k+ turned off with the red LED showing.
Even after waiting for around 10-15 minutes it still didnt respond to anything, which is when i pulled the plug and plugged it back in and now it doesn’t start at all.
Did I mess up by pulling the plug? Do I now have to reinstall from USB?

1 Like

Which color has the LED?
Nothing shown on the TV?
Visible on the network?

LED is off
nothing shown on TV
not visible on the network

That would indicate a power supply issue not a software issue.

Had the following error message on a 4K+
I previous had some problems with a bricked device, @sam_nazarko helped me out with, due to the 4.9 testing, so i am sure it has something to do with that.

There is nothing in the logs due to several reboots after enabling debug logs and disable an VPN addon which spammed the logs.

Logs http://paste.osmc.io/ituqasokuq.vhdl

What to do from here.

All installed fine for me but on boot Bluetooth had been turned off by default.

Thanks to Sam and the team for continuing to work on the project at this difficult time.

Please start a new thread.

Please start a new thread so we can track this issue properly.

1 Like

Thanks for your hard work! Sam, could you please update NOOBS installer too?

1 Like

This has already been done.

My bad, I’m using Matt’s tool to prepare a dual boot SD card but it still is showing only older OSMC build available and it supposedly is using NOOBS directory for that. https://pinn.mjh.nz/ I guess I have to wait for Matt to update that too? Sorry for your trouble Sam.

You need to wait for it to propagate to your mirror.

We don’t push those images as soon as we push the update as we wait a little while to make sure there are no major issues.

I don’t know if PINN uses our mirror system directly.

Great, thank you very much for this information! Stay safe everyone in these hard times :slight_smile:

As always, the update worked flawlessly on my Vero 4K. No errors here. :slight_smile:

Whoever overread the awesome new feature of long press functionality for the Vero remotes: read about it!

As a heavy subtitle user, this one is a blessing:

I think I need to print out a list of all comands and put them next to the remote to get used to them. Anyway, thanks for implementing this, guys! :heart_eyes:


Does this update include the fix to high bitrate audio like in Frozen II that causes the movie’s audio to cutout?

We included the fix some time ago, so there’s no more crashing.

But the dropouts themselves are not fixed in Kodi yet.

I applied the update to my VERO 2, but afterwards none of my videos will play. I tried a few different ones, even ones that played yesterday, but it just gives me the wheel like it is about to, then gives up a few moments later.

Any clues as to what I can do to even begin troubleshooting?

I just saw the issue over here, which seems to be my same issue. I’ll keep an eye out for that fix. Thanks Sam! Stay healthy!

This should now be fixed – just check for another update.