OSMC's March update is here with Pi 3 B+ support - OSMC


#1

OSMC's March update is ready with a wide range of improvements and fixes to keep your OSMC device running in tip-top shape. We've released this update slightly earlier in the month than usual to add support for the new Raspberry Pi 3 B+.


This is a companion discussion topic for the original entry at https://osmc.tv/2018/03/osmcs-march-update-is-here-with-pi-3-b-support/

[TESTING] OSMC skin improvements
#2

Cool to see OSMC still works with the Pi guys to get support out on day one but this one will probably be ignored as there’s still no 4K no HDR no HD audio. I bought a Vero 4K last week so if I win the competition I will be annoyed :frowning:


#3

As per the competition page, if you win, and you have purchased a Vero 4k within the last 28 days, we’ll refund your order.

Cheers

Sam


#4

Thanks Sam for quick support of B+ will definitely be updating my rpi3.

How do you find the CPU speed boost compared with previous is GUI a little snappier?

Will the improved onboard Bluetooth be more stable going forward. Will it have same issues as the previous onboard especially ad2p?

Cheers


#5

At this point, I still recommend using an external Bluetooth adapter; particularly if you are using the on-board WiFi.

The device is about 20% faster. It’s not easy to quantify that in terms of GUI responsiveness.

Sam


#6

This is great news. I’m tempted to buy one of the new Pis just to test out the onboard 5G wifi. I got my OSMC dongle working, finally, but I had an unusually difficult time with it. It would be sweet if the new Pi were “plug and play”.


#7

There are still some conditions where it’s necessary to run commands to configure the internal WiFi on Raspberry Pi (channel 13 usually).

In the future, we can mitigate this by using the internal regdb from the kernel. This isn’t ready yet however.

The 802.11ac WiFi will get you about 80-100Mbps, which is enough for 1080p content on Raspberry Pi. The external dongle will get you about 230Mbps in a good situation. If you have any problems with the OSMC dongle do let us know.

Sam


#8

Yeah, thanks I will give it a try, thanks for supporting.


#10

Thanks Sam.

I’m currently getting between 50 and 60 Mbps with the OSMC dongle, which is on par with what I get using my Windows 7 laptop and my Android cell phone, so I almost certainly don’t have a good situation. I wish I could take advantage of the higher speeds the OSMC router is capable of.

I have 50 Mbps service with AT&T, but I thought that applied only to service outside of my LAN; i.e. to and from the internet. Regardless, if I plug my laptop directly into an ethernet port on the back of my gateway, it connects at near 1 Gbps.

I think I ought to be able to do much better than am I wirelessly but it would not surprise me if AT&T’s gateway is holding my wifi speed at 50 Mbps even if the traffic is local. There is no bridge mode with this gateway. The only way to connect your own router is through DMZ, which is apparently a bit tricky, and probably beyond my capabilities. AT&T is not responding to my questions in any event. If anyone has any insight on how I might address this, I’d sure appreciate it, but I am happy with the OSMC dongle right now. You folks did a lot of work to get me happy, and I appreciate it.

Thanks again.


#11

I HAVE A PROBLEM!!!
I just updated and now my netgear AC wifi dongle is now not detected .
was working before update and I did not backup :frowning:


#12

Please start a forum post with logs so this can be looked in to further. You don’t mention which device you’re using; or which version you updated from, so it’s hard to get an understanding of your problem.


#13

Hi Sam,
Can you comment on the playback of 1080p H.256 videos the Pi3B+?
Thanks!


#14

1080p x265 should play fine at low bitrates.

High bitrates may need an overclock.


#15

RPi3B+ arrived today … and moving over the SD card from a 3B worked without a problem.

Purchase of MPEG2 licence not working (for me at least) on RPT site. Not essential because MPEG2 without GPU acceleration is OK on this device but don’t really want to run it long term like that in case it gets too hot and starts throttling when playing something long. RPT issue been reported by a few people over there and has had an acknowledgement that they know something is wrong.


#16

Hi @sam_nazarko

With March update the A2DP Bluetooth problem (ASLA BLUETOOTH) was solved?

Thanks

Bye


#17

Was it mentioned in the release notes?
But the answer is, no a2dp still not working 100%


#18

With latest update there is audio lags and strange voice tone. Why? Rpi3 (not latest).


#19

Open new thread and provide debug logs


#20

Strange, but already solved by power re-plug.


#21