OSMC's May update is here - OSMC

Does this have effect for bluetooth connections as well, like with a Harmony Elite?
I have quite some remote issues when I play UHD moves, but no issues with any resolution under that.

Yes.

2 Likes

Just updated my Vero 4k and thankfully I didn’t suffer download stuffing on me result wasting data and its running nicely and I do agree that the Vero remote is alot more responsive now compared to pre update state so that’s definitely a boon for sure. So good work on the update.

1 Like

I guess I must be one of the few unlucky ones.
This updates broke my Vero for me just like that last one did.
Eminence 2.0 does not work with this and the last update.
I had to roll back to the December build again to get it to work - which is weird, since I have the same build as the newest one on my PC and there, Eminence works like a charm (none of those xbmc.gui incompatible dependency errors).

Maybe I’ll risk an update again during the weekend to grab logs, but at this time, I’m back on the December build and it just works…

The December version of OSMC was the last version to use Kodi v17.6

We now ship Kodi v18 (Leia),
I’d suggest checking your skin is compatible with v18. If it is, you’ll need to install the v18 version or update it if it’s part of a Kodi repository

The dependency errors sound like you’re trying to use an old version of the skin or it hasn’t been updated

Sam

Hi Sam and the rest of the gang.
I’ve got two problems:

  1. After the may update, the device claims it is not connected to the internet when im using my external adapter.
    The device has an ip. I’m using this external USB adapter .
    If i inspect the traffic with something like wireshark, something seems to be up with the routing:
    ARP, Request who-has 8.8.8.8 tell 192.168.0.x, length 46
    The device is .x, im trying to ping 8.8.8.8
    If i unplug and replug the cable, everything is great unitl next reboot.
    I’ve tried enabling and disabling “Wait for network” in my osmc settings.
    If i disable “wait for network”, the network comes up on next reboot, but on subsequent reboots, the setting seems to be reset.
    Everything works with the built in ethernet adapter - but it’s too slow for some of my files.
    I’m using the built in for now.
  2. The black bars around my videos are now grey. This problem appeared with the april update.
    I’m playing video via the plex add on. Black bars seems to be a known issue on some sony tv’s when playing hdr content. I’m not playing hdr content.
    The colour range is set to 0-255 on the vero, and to full on the tv. If i limit the dynamic range on the vero, the grey bars are about the same grey as the “blacks” in the content.
    To be precise: The blacks in the videos are always correct, the problem is the bars around them.
    In HDR the bars are as black as they are supposed to be. (This workaround is used: 4k HDR too dim/dark - #10 by bmillham - i don’t know if it’s relevant, but i applied it for testing)

Issue support is not handled in the release thread. Please start a new, appropriately titled thread that includes debug enabled logs which demonstrate the issue.

Thanks

sure, i’ll split it out and add some debug logs.

As @actiona has suggested, a new post would be best. Otherwise it can become very difficult to keep on top of things.

Cheers

Sam

Hello, since May update i have a bug on reboot,

after reboot skin is back to estuary and resolution reset to a much lower resolution, in pannel setting it still shows the alternative skin is active and resolution is 1080p, so i had to change these to a new setting ( skin to estuary and resolution to 720 P to set it back to right skin / resolution : Eminance and 1080P )

the latest update fixed the issue for skin, but resolution bug is still here, it is like it reboots to lowest resolution but system menu shows 1080P so i have to set 720 P and then set back to 1080P to get back to proper resolution.

other than that no problem for now,
thank you for your good job happy with my Vero :slight_smile:

Great Update , thx Sam !

Great will update tonight and play …Thanks to all involved…

Please start a post with logs and let us know which device you’re running OSMC on.

Upgrade here also worked fine. All good :slight_smile:

1 Like

Hey, it seems the my osmc menu has disappeared completely? How to get it back or where to find it?

Which skin are you using?
On Estuary and My OSMC you can find it on the main menu. Otherwise you’ll find it under Programs.

I’m using the osmc skin.
Have found it just now, but how to get there is strange:
Main menu, go to apps, then left on the remote (a click on apps does nothing), then chose programm addons, and then I find the my osmc tile there.
That’s not really intuitive, but now that I know where to look its OK.
I had some red led crashes in the last days and hope they will be gone with the May update.
Thanks Sam for your effort!

It’s on the front page of the OSMC skin

In my case not. But it was there before the big jump to Kodi 18.
My main menu has
Pictures, music, movies, series, videos, apps, games, system, search (which does nothing), power, favorites

That doesn’t sound right.
Please start a new post with logs and photos of what you see