OSMC's October update is here with Debian Buster and Kodi 18.8 - OSMC

For best results, update via My OSMC.

Suggest to open a new thread and provide debug logs.

and now ? can i run into problems ?

Hard to say without proper logs, but it doesn’t look like a significant issue, just locales not being generated properly.

mmmmm ok… i wait to 100%. reboot my pi2 and see the final result :slight_smile:

Oh thanks for providing this “new” version :slight_smile:

1 Like

And again nö chance to install Netflix or Amazon Prime :face_with_symbols_over_mouth:

On vero, if i remember it’s works, no works on other device like Raspberry.

Remember also… under the hood there is always and in any case Kodi with all its pros and cons… one for all it’s very difficult you can obtain an official addons for netflix and amazon prime.

EDIT
when I talk about official addons I mean that they are directly developed by Netflix or Prime…and not that come out of the kodi.tv forum developed by some good willing user…

I wasn’t after this on Rpi4 was saying I moved my home automation to a dedicated Rpi4 leaving the vero4k for Kodi and media work anyway. I left behind all the install and dependencies on the Vero 4k of the home automation but would like to blow that away now :slight_smile:

I had some hickups with the update on the RPi2 but nothing serious it seems.

After the update, OSMC booted with an update failed message but the version was correctly shown as 2020.10-1. The log showed some errors with the osmc settings:

ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<–
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <type ‘exceptions.TypeError’>
Error Contents: can’t multiply sequence by non-int of type ‘float’
Traceback (most recent call last):
File “/usr/share/kodi/addons/script.module.osmcsetting.updates/service.py”, line 38, in
m = update_service.Main()
File “/usr/share/kodi/addons/script.module.osmcsetting.updates/resources/lib/update_service.py”, line 244, in init
self._daemon()
File “/usr/share/kodi/addons/script.module.osmcsetting.updates/resources/lib/update_service.py”, line 284, in _daemon
self.position_icon()
File “/usr/share/kodi/addons/script.module.osmcsetting.updates/resources/lib/update_service.py”, line 531, in position_icon
screen_width = screen_height * 1.7777777777
TypeError: can’t multiply sequence by non-int of type ‘float’
–>End of Python script error report<–

Also the manual update did not run again at this point:

WARNING: CPythonInvoker(10): Script invoked without an addon. Adding all addon modules installed to python path as fallback. This behaviour will be removed in future version.
ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<–
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <class ‘socket.error’>
Error Contents: [Errno 2] No such file or directory
Traceback (most recent call last):
File “/usr/share/kodi/addons/script.module.osmcsetting.updates/resources/lib/call_parent.py”, line 18, in
sock.connect(address)
File “/usr/lib/python2.7/socket.py”, line 228, in meth
return getattr(self._sock,name)(*args)
error: [Errno 2] No such file or directory
–>End of Python script error report<–

I rebooted once and no new errors were shown. Did the manual update again and it indeed did some additional updates. No differences in version shown at system info nor myOSMC. All seems good so far now.

Thanks for the report. We’ll look in to this issue.

Hey, thank you for the update. One thing I’ve been seeing with the last few updates is that after starting the update process, my TV turns off, probably because it gets told to do that via CEC.

This isn’t great as I can’t follow what the box is doing until I manually switch it on again.

With this latest update, has there been any change with respect to Wireguard?
I would potentially like to install a wireguard client to be able to connect to my PiHole VPN if im travelling with a Pi.

From what I read on the forums it had been possible to install wireguard but I think it would be likely beyond my technical abilities.
If there is now greater support for Wireguard i might give this a go.

(Basically its for if I want to tether the pi over USB to some wifi, it allocates a new IP every time which makes it difficult to connect to without a mouse or some other control method. I was thinking a link to my VPN might help with ZeroConf, that way I dont need to check the IP in Kodi each time?
When I set a static IP it always seems to loose internet)

Hi there. Thanks for the update! I installed it on my RPi3b. After the first reboot, I got the “Sad Face”, but it went away on its own. I then restarted with only one issue: When Plex starts, there is no left-side menu for Plex any more, and I don’t know how to configure it so that the left-side menu returns.

i keep getting this, not sure why you’re trying to write to /media as that’s the autofs directory for mounts like usb or nfs…

Preparing to unpack .../armv7-diskmount-osmc_1.5.7_armhf.deb ...
Unpacking armv7-diskmount-osmc (1.5.7) over (1.5.6) ...
dpkg: error processing archive /var/cache/apt/archives/armv7-diskmount-osmc_1.5.
7_armhf.deb (--unpack):
 unable to create '/media/README.dpkg-new' (while processing './media/README'): 
Permission denied

i managed to to the upgrade eventually using apt-get -f install but this package is getting stuck all the time now on all three vero4k+'s.

edit: systemctl stop autofs && apt dist-upgrade && reboot did it, bit naff though.

Hi Sam, I ran update on my Vero 4K+ and everything seemed to go OK, but I noticed in System Info that my kernel is 3.14.29-160-osmc. This does not sound right to me. I also ran update on RP3 and kernel is now 4.19.122-2-osmc. Both are Build: OSMC running Kodi 18.8 and Compiled: 2020-10-17. Any thoughts?

Glen

Wireguard as a kernel module is available in Linux 4.9 for Vero 4K/4K+
It will be available on Pi soon too.

But you will need to install and configure this yourself.

I’d be surprised if this was CEC related. It’s possible your device is switching to a resolution unsupported by your TV. A new thread could be opened to help us diagnose the issue.

The changes to Kodi are minor (18.7 -> 18.8). I’d suggest starting a new post outlining your issue in more detail.

autofs isn’t something that we include by default, but we do support it. It might be worth checking your configuration is correct.

These are the correct versions. It looks like both of your systems have updated successfully.

Ok, so kernel is still 3.14… on Vero 4K? I wasn’t sure because I have my other Vero 4K configured to get kernel 4.9 [Testing] build.

Thx
Glen

Hi

Yes – still 3.14 for now as there are still some issues to resolve with 4.9

Sam

This is expected behavior, at least with a RPi (no clue w/Vero), If you have the CEC options set to allow TV power control. I think if you manually reboot via Kodi the TV stays on but if you issue “reboot” via CLI the TV turns off and then comes back on when Kodi loads again. This is not new behavior as i’d noticed this before the June 2020 update when I first enabled those options as part of OSMC remote keymap testing.

I noticed problem with ALSA and Pulseaudio. After upgrade I lost Pulseaudio from “audio output” in KODI. Also ALSA sink in Pulseaudio is only mono (without other profile available). Aplay -l shows Pulseaudio, and its accessible from console, but not seen in KODI. I think about fresh install, but no image available.
Can anyone confirm?