OSMC's October update is here with Kodi 17.5 - OSMC

So from the changelog the improvements for VC-1 (related to playback at 24p) didn’t happen to be included in this release, right? Maybe November update then?

For example Jurassic Park (German Blu-ray MKV) is still unplayable for me.

Hi

As per the release announcement, there haven’t been any changes to VC-1 playback included in this release.

We understand there’s demand to improve this and we’re working on this. If there is an applicable solution for v17, it’s not far off.

We’ll keep you posted in the VC-1 threads when we have improvements to test

Thanks for your patience

Sam

1 Like

Burrito78, until a fix is implemented, why not just take your VC1 titles and encode to h264 using Handbrake? I always do this with all of my Bluray movies, even those encoded in VC1. The new h264 encode is virtually indistinguishable from the original VC1 encode and plays back perfectly.

Does this mean the kodi-send --action="CECStandby" command will now work?

I was getting an error that a package wasn’t available when I tried to apply this update, and when I did it through ssh I got this:
E: Failed to fetch http://apt.osmc.tv/pool/main/v/vero2-mediacenter-osmc/vero2-mediacenter-osmc_17.5.0-1_armhf.deb Hash Sum mismatch

Is there something wrong with the hashes for the Vero 2 or is there something I can do to apply this update?

Try check for updates again, and run apt-get clean

Sam

Same thing:

root@Oswin:/home/osmc# apt-get clean
root@Oswin:/home/osmc# apt-get update
[…]
Reading package lists… Done
root@Oswin:/home/osmc# apt-get dist-upgrade --fix-missing
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… The following packages were automatically installed and are no longer required:
libass5 libgssapi3-heimdal libheimntlm0-heimdal libjasper1 libkdc2-heimdal
Use ‘apt-get autoremove’ to remove them.
Done
The following packages will be upgraded:
vero2-mediacenter-osmc
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 41.3 MB of archives.
After this operation, 794 kB disk space will be freed.
Do you want to continue? [Y/n] yes
Get:1 http://apt.osmc.tv/ jessie/main vero2-mediacenter-osmc armhf 17.5.0-1 [41.3 MB]
Fetched 41.3 MB in 30s (1,332 kB/s)
E: Failed to fetch http://apt.osmc.tv/pool/main/v/vero2-mediacenter-osmc/vero2-mediacenter-osmc_17.5.0-1_armhf.deb Hash Sum mismatch

The file looks OK here.

Try again in a few hours; and make sure you’re not behind an HTTP proxy.

Sam

After the update, it’s noticeably quicker in the UI here on a Pi3. Thanks!

Anyone else using Hyperion?

I’ve lost all my lighting…
I’ve fully removed and reinstalled it all, checked SPI is enabled etc etc.

Something change in the kernel to stop it from working?

Hi,

Sorry to hear that you’re experiencing a problem with Hyperion.
I’d advise trying a new forum post.

It’s not clear which device you are using, which makes it hard to advise, and you haven’t provided any logs, which makes it difficult to advise.

Sam

Can’t speak for anyone else but re-encoding my 42 plus blu-ray VC1 remuxes would take up far too much time and effort.

Plus “virtually indistinguishable” isn’t really good enough when watching on a 120" screen.

I’m fine with waiting and seeing if/when the issue gets resolved though.

1 Like

I use a 100" screen, and when done properly, re-encoding a VC1 to h264 looks fantastic. You’d be hard pressed to find any difference between the original and the new h264 encoding. But, yes, it does take time. It’ll take between 7 and 12 hours per title, depending on the setting. I set it up and let it do its job overnight. Last night, in fact, I set up The Mummy trilogy to re-encode from VC1 to h264. It’ll take about 26 hours, but so what. Once it’s done it’s done and I won’t have to worry about VC1 and even the file size is reduced by 20% or so.

If you’d like to know what settings I use I can share them.

Yeah that would be great if you could let me know your settings.

I guess part of the reason I’m not happy about re-encoding is because I’m paranoid that even If can’t see a difference right now it is still there, and once I upgrade my current (outdated) tv and pj it will be more apparent.

Whereas keeping the remux means I’ve always got the best available version.

Still… I’m willing to experiment a bit so let me know what you use and I’ll give it ago. Vc1 just seems to be causing a headache for a number of playback devices not just the Vero 4k. I’m not getting smooth playback on nightly builds of Kodi on the Shield either.

I personally encode with the following settings for x264 in Vidcoder (http://vidcoder.net/) for 1080p content. Vidcoder is basically a better UI for Handbrake.


Audio passthru of course and no video filters. Cropping only when needed of course (e.g. black bars on top of bottom).

My settings are basically more or less the equivalent of the high 4.1 profile with a very-slow preset beside some tweaks I did years ago and don’t even remember why exactly :slight_smile:

With CRF 18 you should not see any difference, sometimes the size might even be larger than the actual source Blu-ray depending on the video stream itself.

Never encountered a Bluray where I had to go lower than CRF18 personally. Your mileage may of course vary with some titles and you might try even going as low as CRF16. If you are worried about difference maybe settle on CRF17 then and don’t look back. :slight_smile:

Just give it a try what the result is for you. At your 110" screen you probably already seeing the shortcomings of the transfers and not of the re-encode. At least I can on a decent projector at this size for 1080p content.

Is there a difference? For sure the bits are difference as it is re-encode. But from my experience I cannot see them at all - it is mathematically different. I experimented a bit until I had my settings in regards to size/quality for storage.

If you are short on size for many movies, you can go up to CRF20 or more. But then you will start to see difference in the encodes. Not necessarily a problem depending on the source material. A lot of Blurays out there with ton of bitrate but still piss poor picture quality or general encoding errors (usually non mainstream movies).

Takes about 6-8 per Bluray on my box (4770K). I just let it ran over night. Encoded about 500 Bluray over the years for archival and easy retrieval from my Mediacenter.

HEVC instead of AVC is a different topic. Come back in a year or two in regards to x265. Right now it is better at low bitrates, but the quality is not up to good x264 encodes when it comes to good 1080p encodes. Part of it is the preprocessing that tends to blur the picture. Same deal as x264 initially, which took also some time to be usable in general. And if you hardware can handle 10bit HEVC it can usually handle 10bit AVC as well. With 4K sources so we can start to argue here, also as well when talking upscaled encodes.

1 Like

My Handbrake 1.0.7 Settings are:

Preset: High Profile

Container: MKV

Picture: Leave as is (1920x1080). Let it auto crop out top and bottom black bars unless you have a title that has a mix of IMAX and non-IMAX scenes (like Interstellar).

Filters: No changes

Video: H.264, Framerate = Same as source, Encoder Preset = Slow, Encoder Tune = Film, Encoder Profile = High, Quality = Constant Quality, RF = 17

Audio: Always use the appropriate pass-through (eg. DTS-HD or Dolby TrueHD), especially if you want to keep DTS:X and Dolby Atmos metadata intact.

Subtitles: Add any you like here.

Give it a try and let me know what you think. How long it takes will also depend on the type of CPU you’re using. I use an old Intel Core 2 Q6600 quad core exclusively for re-encodes. Newer processors will do the job much faster than mine.

I’ve been updating OSMC from the GUI for the last few months but with this new update i get an error. This is what the error says when i run a “clean” or “dist-upgrade” from ssh:
Errors were encountered while processing:
_ /var/cache/apt/archives/rbp2-image-4.9.29-10-osmc_10_armhf.deb_
E: Sub-process /usr/bin/dpkg returned an error code (1)
/usr/bin/apt-get: line 27: 28434 Illegal instruction “$REAL_APT” “${new_args[@]}”

Any ideas?

Post the output of cat /usr/bin/apt-get

This should be in a new post really.

Sam

I get an update error when trying to update from September 17 to October 17. Have tried this several times over the last few days - any advice great appreciated!

Open a new thread and provide logs either via MyOSMC or via command line grab-logs -A