Update to 17.6 Fails

Please run a grab-logs -A and post the URL it returns.

Sure: Logs available at https://paste.osmc.tv/okaniyuvaq

The immediate downloading of files is a separate issue that I’ll discuss with Sam.

The hash sum failure is either caused by a bad list of packages or the packages themselves are being corrupted (or both, I guess).

Try this:

sudo apt-get clean
sudo rm -r /var/lib/apt/lists/*
sudo apt-get update
sudo apt-get dist-upgrade --fix-missing

Inside the update:
Get:24 http://ftp.debian.org stretch/non-free Translation-en [79.2 kB]
Err http://ftp.debian.org stretch/main armhf Packages

Ign http://ftp.debian.org stretch/main Translation-en                                                                                                                                                                                                                         
Err http://ftp.debian.org stretch/main armhf Packages                                                                                                                                                                                                                         
  
Err http://ftp.debian.org stretch/main armhf Packages                                                                                                                                                                                                                         
  404  Not Found
Fetched 13.3 MB in 27s (485 kB/s)                                                                                                                                                                                                                                             
W: Failed to fetch http://ftp.debian.org/debian/dists/stretch/main/binary-armhf/Packages  404  Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

And inside the dist-upgrade:
Get:6 http://apt.osmc.tv/ stretch/main wireless-firmware-osmc all 1.1.4 [2,657 kB]
Fetched 25.9 MB in 15s (1,721 kB/s)
Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/^(.?)(\)?${ <-- HERE ([^{}]+)}(.)$/ at /usr/share/perl5/Debconf/Question.pm line 72.
Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/${ <-- HERE ([^}]+)}/ at /usr/share/perl5/Debconf/Config.pm line 30.
Preconfiguring packages …
(Reading database … 23787 files and directories currently installed.)
Preparing to unpack …/tzdata_2017c-0+deb9u1_all.deb …
Unpacking tzdata (2017c-0+deb9u1) over (2017c-0+deb8u1) …
Setting up tzdata (2017c-0+deb9u1) …
Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/^(.?)(\)?${ <-- HERE ([^{}]+)}(.)$/ at /usr/share/perl5/Debconf/Question.pm line 72.
Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/${ <-- HERE ([^}]+)}/ at /usr/share/perl5/Debconf/Config.pm line 30.

Current default time zone: 'America/New_York'
Local time is now:      Tue Jan 16 15:49:08 EST 2018.
Universal Time is now:  Tue Jan 16 20:49:08 UTC 2018.
Run 'dpkg-reconfigure tzdata' if you wish to change it.

(Reading database ... 23789 files and directories currently installed.)
Preparing to unpack .../mediacenter-skin-osmc_17.0.2-6_all.deb ...
Unpacking mediacenter-skin-osmc (17.0.2-6) over (17.0.2-3) ...
Preparing to unpack .../wireless-firmware-osmc_1.1.4_all.deb ...
Unpacking wireless-firmware-osmc (1.1.4) over (1.1.3) ...
Setting up mediacenter-skin-osmc (17.0.2-6) ...
Setting up wireless-firmware-osmc (1.1.4) ...
E: Failed to fetch http://apt.osmc.tv/pool/main/v/vero2-source-3.10.105-8-osmc/vero2-image-3.10.105-8-osmc_8_armhf.deb  Hash Sum mismatch

E: Failed to fetch http://apt.osmc.tv/pool/main/m/mediacenter-addon-osmc/mediacenter-addon-osmc_3.0.654_all.deb  Hash Sum mismatch

There are so many things going wrong with your update(s) that I can only suggest a full reinstall. Back up your configuration first.

I just did that two month ago, and even that didn’t work until Sam did something.

/usr/bin/apt-get-real dist-upgrade --fix-missing looks odd to me.

Backup and reinstall is the first thing I’d recommend if possible.

Sam

So just to be clear, you did a full reinstall 2 months ago and had exactly the same problems during the first update?

It’s possible that @sam_nazarko was suggesting you wait a while on the assumption that the problem was probably just a temporary network glitch.

Perhaps your Vero2 is having a few hardware issues - or perhaps your ISP is messing with the data feed. Unfortunately, as things stand, the Debian and OSMC repos are on unencrypted http, so are potentially vulnerable to corruption by transparent proxies. If you can try updating with a VPN, that might narrow things down a bit.

Is there a way to check for hardware issues?

My ISP is Comcast, so it’s possible they are doing things like that, but I do not have a VPN to try.

Also, I just reinstalled everything, restored from backup, and now I get a “File Exists” error whenever I connect to some (not all) of my network shares.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

New problem requires new logs.

The NAND spits out a warning to dmesg if you have bad blocks. This doesn’t seem to be the case here.

You could change the OSMC repo to use Index of /osmc/osmc/apt which is an HTTPS mirror.

I believe you can do the same for Debian, but beforehand you need to install apt-transport-https. This will stop Comcast meddling if they are doing so.

It’s not quite so simple. The great majority of Debian mirrors do not support TLS and there’s no official list that I’m aware of where the TLS mirrors are listed. There’s a python3 script here that pulls the full mirror list from Debian worldwide mirror sites and tries each one in turn. When I ran it only 76 out of a possible 379 mirrors supported TLS.

I believe there are no mirrors of security.debian.org - and AFAICT it is http-only.

@LexPendragon In additional to monkeying around with http traffic, I came across a thread here where people were discussing the alleged hijacking of DNS traffic. A piece of python code, namebench came up that is supposed to detect such nonsense. I tried it on my own network and, well, it complained that someone was hijacking my DNS. Yep, that would be me.

There are lots of clever ways to detect things like transparent proxies. Usually by breaking them

Just now, I got that same update error from my first comment, yet in apt-get there were no updates.

osmc@Oswin:/$ sudo apt-get dist-upgrade
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

If you installed the latest version from osmc.tv/download; there are no published updates to yet be installed.

Sam

That’s what I figured, but it still popped up with an error on my screen.

Can you try a neighbour / friend’s WiFi or tether from your phone?

I do not have access to either of those, no. Even if so, why would it give me that error screen if there weren’t any automatic updates to get?

You’ve been asked for logs, you probably should post them.

Because the update check would be failing.