OSMC's October update is here with Kodi 17.5 - OSMC

OSMC's October update is ready with a wide range of improvements and fixes to keep your OSMC device running in tip-top shape. Kodi 17.5 has been released with a variety of fixes, and OSMC now ships with this version.

This is a companion discussion topic for the original entry at https://osmc.tv/2017/10/osmcs-october-update-is-here-with-kodi-17-5/

17.5? I updated right now and it tells me i’m on Kodi 17.4

grep Kodi .kodi/temp/kodi.log | head -3
18:22:42.121 T:4108423168 NOTICE: Starting Kodi (17.4). Platform: Linux ARM (Thumb) 32-bit
18:22:42.121 T:4108423168 NOTICE: Using Release Kodi x32 build (version for Vero)
18:22:42.121 T:4108423168 NOTICE: Kodi compiled Oct 22 2017 by GCC 4.9.2 for Linux ARM (Thumb) 32-bit version 3.16.39 (200743)

Patience… Some mirrors may still be syncing up. Try again in an hour.

Sorry, I thought he had updated because he had found an update.

Still no changes regarding Multichannel Audio issues?

Very happy to see a fix for the high CPU load and temperatures. I was definitely suffering from the latter.

Anyway i thought it was updated, new image downloadable reports 20171021, different from latest build of 20171001. So i think it should be updated but it tells me kodi 17.4. But maybe some update has to come yet.

We had a problem with one package not being updated properly. This has now been rebuilt and pushed. You can either check for updates again manually or wait until you receive an update notification.


Found it, 803kb update. Unpacking vero3-mediacenter-osmc (17.5.0-1) over (17.4.0-15)


Unfortunately we were unable to reach a consensus so there haven’t been any changes. When everyone is happy with the changes, we will push them again.

Our proposed changes were in line with the SoC recommendations, but clearly this was not well received by everyone. The update doesn’t revert any changes you may have made after the September update.

I’ll follow up on this shortly. I pinged a couple of affected users in September but didn’t receive a response yet


803kb is quite small. Probably the increased size of the new package


yes it was. Now it reports correctly kodi 17.5, all is up to date!

So from the changelog the improvements for VC-1 (related to playback at 24p) didn’t happen to be included in this release, right? Maybe November update then?

For example Jurassic Park (German Blu-ray MKV) is still unplayable for me.


As per the release announcement, there haven’t been any changes to VC-1 playback included in this release.

We understand there’s demand to improve this and we’re working on this. If there is an applicable solution for v17, it’s not far off.

We’ll keep you posted in the VC-1 threads when we have improvements to test

Thanks for your patience


1 Like

Burrito78, until a fix is implemented, why not just take your VC1 titles and encode to h264 using Handbrake? I always do this with all of my Bluray movies, even those encoded in VC1. The new h264 encode is virtually indistinguishable from the original VC1 encode and plays back perfectly.

Does this mean the kodi-send --action="CECStandby" command will now work?

I was getting an error that a package wasn’t available when I tried to apply this update, and when I did it through ssh I got this:
E: Failed to fetch http://apt.osmc.tv/pool/main/v/vero2-mediacenter-osmc/vero2-mediacenter-osmc_17.5.0-1_armhf.deb Hash Sum mismatch

Is there something wrong with the hashes for the Vero 2 or is there something I can do to apply this update?

Try check for updates again, and run apt-get clean


Same thing:

root@Oswin:/home/osmc# apt-get clean
root@Oswin:/home/osmc# apt-get update
Reading package lists… Done
root@Oswin:/home/osmc# apt-get dist-upgrade --fix-missing
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… The following packages were automatically installed and are no longer required:
libass5 libgssapi3-heimdal libheimntlm0-heimdal libjasper1 libkdc2-heimdal
Use ‘apt-get autoremove’ to remove them.
The following packages will be upgraded:
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 41.3 MB of archives.
After this operation, 794 kB disk space will be freed.
Do you want to continue? [Y/n] yes
Get:1 http://apt.osmc.tv/ jessie/main vero2-mediacenter-osmc armhf 17.5.0-1 [41.3 MB]
Fetched 41.3 MB in 30s (1,332 kB/s)
E: Failed to fetch http://apt.osmc.tv/pool/main/v/vero2-mediacenter-osmc/vero2-mediacenter-osmc_17.5.0-1_armhf.deb Hash Sum mismatch

The file looks OK here.

Try again in a few hours; and make sure you’re not behind an HTTP proxy.