Multichannel audio incorrectly mapped

Vero 4K, 2017.06-1, currently running the 10bit test kernel, but I have also tested without it and have gotten the same result (logs)

Multichannel audio files are incorrectly being mapped to 5.1 PCM output. I have a 5.1-capable receiver and first noticed this when listening to some 5.1 FLAC that should’ve been using the rears but wasn’t. I downloaded some test files and noticed that the surround L&R were being mapped to front L&R and LFE was being dropped. I tried all possible options for System > Audio > Output Configuration (Fixed/Optimized/Best match). Audio device is AML-M8AUDIO, HDMI and Number of Channels is 5.1. I have tried playing the same files with Kodi 17.3 on my Mac using HDMI output to my receiver (5.1 PCM as well), and all map channels correctly. I have tried disabling System > Audio > Allow passthrough and the DTS file below is mapped incorrectly, but of course the mapping is correct if I allow the pure DTS to be passed thru & decoded by my receiver (Marantz SR7010).

5.1 channel test files (all will announce which channel they should be playing from):

  1. FLAC file
  2. DTS file
  3. FLAC file 2 (converted from the above DTS file)
  4. WAV file
  5. AAC file

Can you take a photo of the audio settings?
Are you saying this only occurs with 5.1 when streaming as PCM?

Your logs aren’t debug logs so hard for me to see what’s going on.

They are debug logs… NOTICE: Enabled debug logging due to GUI setting. Level 2.

Yes, it only occurs when the audio is converted to PCM because it has to be (FLAC) or because pass-thru is disabled (DTS). I can try 5.1 channel AAC as well but I imagine it’ll have the same issue as FLAC.

Here is a 5.1 AAC test file and logs captured while playing it. The same channel mapping issue occurs.

Okay – I’ll look at this shortly. Thanks for letting me know that it also affects the 10-bit kernel. This might be a recent regression, and I suspect it probably worked OK before a recent update.

Thanks. I would consider this a bug of the highest-priority since my primary use for my Vero is playing Multichannel FLAC. The 10-bit stuff is more just for future-proofing - very little content available there yet.

If it’s urgent, I’d suggest trying an older version. The last audio changes were in the June update and I suspect that’s when they were introduced if you have only noticed them.

Of course everyone’s issues are equally important and a high priority to us.

One workaround for now would possibly be using AC3 transcoding.

Sam

As far as I’m aware, there isn’t a July update so I assume you mean the June update. Also, AC3 transcoding is not a solution - converting from a lossless to lossy format defeats the purpose.

UPDATE: I looked and the downgrading process seems painful, requiring wiping the device and installing from an image. I’d like to avoid going through that hassle. Honestly this box is already enough of a hassle.

Would this problem be in any way realated to this?

There were audio changes in the June update and the issue is no doubt related to those changes. I suspect the May update is not afflicted with this

Unless you have a lot of software packages installed; a backup and restore from My OSMC will do the trick and takes five minutes.

Very sorry to hear that. I’ve PMed you to ask what we can do to make things better. Currently Vero 4K is considered to be one of the best devices on the market with good response times to issues. You may find another solution that meets your needs; but we always pride ourselves on resolving issues promptly (past and future). I suspect you will struggle to find that elsewhere, coupled with the feature set the Vero 4K offers.

Sam

2 Likes

Any good step-by-step instructions on how to do this including installing the older image?

Yep

Go to OSMC -> Updates -> Backup and you can create a backup or restore it.
And to reinstall OSMC (needs a micro SD card), see Reinstalling OSMC - Vero 4K - OSMC.

1 Like

I assume that wiping the device would wipe the backup, no? So, I need to backup to an external drive or something…?

You can back it up on to an SD card, network, USB stick. You’ll be prompted to select a backup and restore medium when you choose this option.

1 Like

Ok, I can confirm that the backup/reinstall/restore process was pretty straightforward. Thanks for linking me to the docs which I probably should’ve been able to find on my own :slight_smile:

I can confirm that reverting to 2017.05-2 resolves the channel mapping issue, however there is some slight crackling with all of the test files when the rear channels play. I had never explicitly tested the rear channels before discovering this issue recently, but had noticed it on & off again when playing back videos with 5.1 AAC tracks - not reproducible enough to be a reportable issue, but worth noting nonetheless.

OK – stick with 2017.05-2 for now, and I suggest you avoid updates until we can address this situation

I understand that playing back multi channel FLAC is your primary use case (and it is for others too), so was surprised we hadn’t seen reports yet. It needs further investigation.

Sam

As I was involved in testing the audio improvements, I’m also guilty… :see_no_evil: My primary focus was on 192kHz to work properly and with that I only looked for my AVR to show and play 192kHz content. But not expecting this issue, I didn’t listen longer and therefore didn’t notice that three (C, LB, RB) of my speakers were staying silent.
I can confirm now after another test that 5.1 FLAC files are only played via the front speakers as stereo.

It’s not my main use of the Vero 4k, so not a big deal for me, but it would be nice to have this fixed obviously! :grin:

Hi all,

are there any new on this issue? I am very much looking forward to play multichannel flac in 5.1, resp. 7.1.

I assume that this issue wasn’t fixed in the July update. I am currently using the June Firmware.

Thanks, Marc

Try updating to the July release :slight_smile:

Hi Sam,

Just updated -but no effect. Only 2.0. My Anthem AVM60 says MultiPCM but powers only 2 speakers. (like before). :unamused: