Multichannel (non-passthrough) surround sound stopped working after June update

Hi Sam, any update on a fix for this problem?

Regards,

Jason.

Not at this time. When there is progress I will update the thread.

For now you can use an older version or use the workaround

Sam

Actually reinstalled after the installation of the bad “patch”, with the latest update and everything is working as normal, 5.1 selected (no passthrough) and DTS playing through the back speakers again. Also showing DTS : Neural X on my Denon X2300W.

Version: OSMC July 2017 2017.07-1

Hi Duncan,

DTS will be OK

I believe the issue only presents when using multi-channel PCM without passthrough enabled
I assume that @Brozzie’s comment was about the audio issue; rather than the update blip (which has now been fixed and won’t happen again)

Sam

True. Weird, I had no back surround on DTS(-HD) and DS/DD. After reinstall I do. Probably different error. I checked and with AAC 5.1 my back surround does not work. But found only one movie with AAC 5.1. So not a real problem for me. If I can help in any way, let me know. I have Star Trek (2009) on Blu-Ray disc, a version with AAC 5.1 and a rip with DTS so I can test accordingly.

I’m working on this. I’ll let you know when I need some improvements tested, thanks for the offer :slight_smile:

Sam

Hi Sam, any news with this issue,

Regards,

Jason.

Hi @Brozzie

Hopefully the issue is now addressed.

I’d appreciate it if you could test this and provide feedback before we release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv jessie-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Hi Sam,

Installed the update. Is this the correct kernel.

Linux osmc 3.14.29-33-osmc #1 SMP Sun Aug 27 02:37:42 UTC 2017 aarch64 GNU/Linux

Updated from
Linux osmc 3.14.29-28-osmc #1 SMP Tue Aug 1 00:00:14 UTC 2017 aarch64 GNU/Linux

I am using HDMI passthrough, with a 7.1 system. Output config is best match.

First I tried a file with a 5.1 aac track, my amp displays it as 7.1 PCM but there is still only sound coming from the FL and FR speakers. I would have expected it to display as 5.1.

Secondly I tried a 7.1 aac track, and same result, sound only coming from FR and FL speakers.

I then tried Atmos and dts hd and dts tracks which work as expected.

See attached log

https://paste.osmc.tv/owasiraheh

EDIT 1
on AAC 5.1 the audio stream is displayed as FL,FR,LFE,BL,BR,aac,32 bits
On AAC 7.1 the audio stream is displayed as FL,FR,LFE,BL,BR,SL,SR,aac,32 bits

Both displayed as 7.1 PCM on my receiver

Most other streams Atmos/dts hd/dts display audio streams as RAW 8 bit

Regards,

Jason.

If it’s helpful to you, I have a bunch of test files available in this post

Hiya, I tested these files and surroundTestDTS.dts.wav is the only audio file that worked as expected, all others seem to have audio just coming from FL and FR

Surround51.flac displays as 7.1 pcm on my avr.
SurroundTestDTS.dts.wav displays as 5.1 dts and works as expected
SurroundTestDTS.flac displays as 7.1 pcm
SurroundtestDTS.wav displays as 2 channel stereo on avr
Chld-BLITS-EBU-narration(1).mp4 displays as 7.1 pcm
Chld-BLTS-EBU-narration.mp4 displays as 7.1 pcm

My avr is a pioneer vsx-930. i hope this helps, although it’s probably nothing you didn’t already know.

Did you try the test Sam recommended above?

Regards,

Jason.

I assume that was the August update he was having you test, which is officially released now. @sam_nazarko?

I’m planning to install it to test anyway but can really test anything on my box as I’ve gotten quite comfortable with the backup / restore process.

Hi

There won’t be any improvements to this situation in this version. I will update you when I have some further ideas.

Sam

1 Like

Unfortunately, I am experiencing the same issue. No surround sound only FL and FR but the receiver says multichannel.

Please try the fix here: Multichannel audio incorrectly mapped - #50 by sam_nazarko. If no improvement, please post debug logs and describe your equipment.

I’ve installed the December update today and the issue seems to finally be gone. Thank you for the fix.

2 Likes

Hi there,

I’ve installed the December update too but this issue reappear.
I have to downgrade to 2.0 channels to finally have the movies voices…

Have you any fix please?

Posting twice won’t get you an answer any quicker.

Sure!
Sorry that’s not what i wanted

Can you start a new thread for this if you haven’t already?

Cheers

Sam