Multichannel (non-passthrough) surround sound stopped working after June update

I’ve updated my Vero 4K last week and since then I’m not getting surround sound for videos with AAC 5.1/7.1 sound. Surround sound in videos with Dolby Surround and DTS works fine.

What is weird is that my AVR shows that it receives multi channel sound, but I only get sound from FL and FR speakers. It seems like Vero 4K sends multichannel sound, but all channels except FL and FR are silent. There is almost inaudible hiss from rest of the speakers, which starts when I start the video and disappears when I stop it, so they do become active.

I’m pretty sure it’s OSMC / Vero 4K problem, because when I disable passthrough and play a Dolby Surround video, there is no surround sound anymore. Before the update everything worked fine.

My AVR is Denon AVR-X1300W connected to Vero 4K through HDMI.

Exact same problem for me Sam, all was good before June update.

We need to see some logs from you guys demonstrating the issue please.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Hiya

Logs are here

Just used a 30 second clip, is that ok,

https://paste.osmc.tv/bekirimudi

I’ll paste my log when I get home today, but I skimmed through @Brozzie’s log and this doesn’t look ok to me:

12:04:18.358 T:4072666096   DEBUG: CAESinkALSA::GetChannelLayout - Requested Layout: FL,FR,FC,LFE,BL,BR
12:04:18.358 T:4072666096   DEBUG: CAESinkALSA::GetChannelLayout - Got Layout: FL,FR,UNKNOWN1,UNKNOWN1,UNKNOWN1,UNKNOWN1,UNKNOWN1,UNKNOWN1 (ALSA: FL FR NA NA NA NA)
12:04:18.358 T:4072666096   DEBUG:   Channel Layout: FL,FR,UNKNOWN1,UNKNOWN1,UNKNOWN1,UNKNOWN1,UNKNOWN1,UNKNOWN1

AAC cannot be passed through: it’s not supported by any receivers

Instead it needs to be sent as LPCM. There were some audio changes in the June update to fix: pops, audio sometimes not working and Atmos.

Can you take a screenshot of your audio settings?

I know this. OSMC does decoding and sends multichannel LPCM output through HDMI. So you still get surround sound.
The issue is that after the last update all channels, except FL and FR, are silent in this case.

From the memory:

Output device: AML-<something>, HDMI
Number of channels: 7.1
Output configuration: Best match
Resample quality: High

I’ll make a screenshot of my audio settings this evening. But, as I said, non-passthrough surround sound worked fine before June update. I didn’t change any settings since then (neither in OSMC, nor on my AVR).

AAC is being displayed as PCM on the receiver, and my settings haven’t changed since the update. See shots, they are prob the same as Oleksii’s.

You can enable AC3 transcoding (I prefer this for AAC streams) or try Fixed output channels

Do you only hear L and R (I.e no center) or is the audio being downmixed to 2.0

Sam

Yes Sam, just front left and front right, no center or rear surrounds

Enabling AC3 transcoding will cause the audio to be transcoded to DD and then passed through. It’s a temporary workaround for now.

Sam I enabled Ac3 transcoding and it worked, but I had to specify my speaker setup being 2.0 instead of 7.1 and so now my receiver outputs 7.1 aac as 5.1 and but like you said, it’s just a temporary work around. AAC worked great for me before the update.

The AC3 transcoding workaround worked for me too.

Here is my debug log: https://paste.osmc.tv/aduvehobek
And my settings are the same as @Brozzie’s, except for GUI sounds.

Hi Sam, with this fix is aac transcoded to ac3 so will there be some compression of the audio stream leading to reduced quality - however slight?

Is this only for the aac stream, and won’t affect hd streams or dts.

Thanks.

I believe DTS and DD are working fine (afterall transcoding uses DD passthrough)

You shouldn’t hear a difference with the AC3 transcoding.

I will look in to this – but fortunately the new audio improvements have been quite well received so it looks like a minor bug

Sam

Thanks Sam. Miner bug = hopefully easy fix. Especially since it was previously working.

Same problem here. Had to select 2.0 to be able to select transcode in Kodi/OSMC. Solved the issue. Also solved the problem that my TV switched to another HDMI port (LG 55OLEDC7V). That was unexpected to say the least.

I have a Panasonic 58ax802 and I was experiencing that too, was wondering what was causing it. Hdmi 4 is my 4k input, and Vero was switching to HDMI1.

Also, and I know this is not of major concern currently, but with this problem, I have aac 7.1 movies, and with the workaround they output as 5.1. Any fix in the pipeline?

This might be CEC related; there’s been a few issues with active source changes (but they affect all platforms at this time unfortunately) and it is nothing unique to Vero 4K.

Once I get back from my trip, I’ll take a look (couple of days).
The main focus in the last update was fixing the popping noises and some Atmos issues (which are now thankfully gone).

Sam

Thanks Sam