September update breaks 5.1 Audio

Hi John,

First, I’d like to just say that I can’t fix problems that I’m not made aware of.

In August, I see that you posted about a Bluetooth streaming issue. Bluetooth however is still experimental and that’s why we don’t yet include it in OSMC out of the box. There is a slight risk that it won’t function as expected sometimes; and it isn’t regression tested fully across updates at this time because some further changes are planned.

I wouldn’t recommend basing your decision not to update OSMC on an experimental package.

Can you confirm whether your audio issue is still present in the September version of OSMC? There were a few audio fixes to fix a couple of problems introduced in the July update when we enabled Atmos and 192Khz support. The main problems introduced here were an incorrect channel mapping for LPCM and muted channels. I understand that this is now fixed.

I didn’t find a post from you about DVBLink issues, so didn’t know that you were afflicted with this problem. There were some improvements to Live TV playback in the September update, and the reports have been quite positive.

Obviously we want to avoid regressions; but they are inevitable. In the unlikely event they do happen we try and fix things quickly. For example, there was a disk automounting issue last night on Raspberry Pi devices; but this was resolved within twenty minutes and made available to users within half an hour.

This suggests that there might be a problem with your DVBLink backend here; but I am not the best person to help resolve that. The DVBLink forums might help you with that one.

We effectively have this in the form of the staging repository; which we often suggest people use to test immediate fixes. I’m aware that there are some people using this test repository as a daily driver.

All of the updates that we release have been tested by some users before their release. You can find notes on the audio changes in the thread I linked to in my previous post.

Sam

I haven’t had a report of this yet.

Can you post a screenshot of your audio settings as well as briefly describe your setup (whether or not you use passthrough; and if so; what formats your receiver supports).

It’s not practical to downgrade as the solution will never be found; and it’s likely that we can resolve the problem more quickly than a downgrade.

Sam

Hi Marciano,

I had a similar issue a couple weeks back where I suddenly started getting horrible crackling from the UI sounds after video playback ended. I eventually tracked it down to an HDMI cable that had just barely been dislodged from the Vero. Try re-seating your cable to see if that helps.

Is the repo apt-get’able ? If so, do you mind sharing me the sources.list ? :slight_smile:

It’s written in many many threads
deb http://apt.osmc.tv jessie-devel main

NB: when we move to Stretch, it will become stretch-devel.
The repo is 1:1 with stable at the moment as we just pushed an update

Sam

1 Like

Thanks Sam,

At the momentt i’m not able to post a screenshot of my audio settings i’ll do that later in this evening.

But i have every option in passtrough enabled.
AC3
EAC3
DTS
DTS-HD
True HD

By channels i have 5.1 and stereo upmix is enabled too.
My receiver supports almost every format except DTS:X and dolby atmos.

If needed i can provide som logs.

Thanks!

Okay – and when you experience the loud noise, is it only occurring when playing content that is being passed through?

Yes it is i didn’t try with passtrough disabled

@sam_nazarko
I realise you cannot sort something you dont know about but on the basis of 20 years with some 30 developers (what luxury!) and a few hundred customers I came to realise there are always minor glitches that one is not made aware of - The fact that we were not told still didn’t stop people giving us less than 5 stars :wink: but that’s life. the DVBlink issue is a case in point. In all of my setups (Vero and Pi) I have managed to discover a workaround by either disabling and reenabling the PVR addon or by clearing the EPg database. Having found a getaround there was less urgency to file a bug - that’s what happens - one lives with shortcomings… but as I am intimating you cant expect non geeks to find such workarounds

Oh and yes I realise that many of my frustrations have been about getting DVBlink to work without pixellation or blue screens saying all 6 tuners in use (not),completely losing the epg etc etc.

Thing is, though, DVBlink has not changed in 12 months.

At least I now have a stable working operation on the June edition of OSMC and the latest 12 month old DVBLink

Anyway I’ve installed the September OSMC update on one PI and DVBlink add-on steadfastly refuses to load - the same error 2000. the logs are uploaded at /ekumerofuj
The workaround that works on previous editions does not work for me on the September update for Pi- I haven’t yet checked about the missing audio on the Vero 4ks yet - I am completely out of free time.

JM

Hi John

I understand that sometimes users work around things without telling you. We sometimes get a few users in and watch how they use OSMC to see if we have missed things from a usability perspective sometimes.

In this case however, it seems that the issue might exist in your DVBLink setup, particularly if the problem is occurring on OSMC across different platforms (Pi and Vero).

There have been several updates to Kodi’s DVBLink add-on this year. Unfortunately we don’t develop or maintain the DVBLink add-on, so I would recommend you ask on their forums.

My understanding is that there are a good number of DVBLink users enjoying PVR with the latest version of OSMC.

If there’s anything you need help with that is directly related to OSMC please give me a shout, or send me a PM if you’d rather take a quick call and discuss this over the phone.

Sam

I’m also seeing the error as described by f0o, although I’m using HDMI rather than optical.

This has started as of updating to latest today.

Relevant (or maybe not relevant, IANAE) settings:
Audio output device: AML-M8AUDIO, HDMI
Channels: 5.1
Output configuration: optimized
Stereo upmix: on
Allow passthrough: on
AC3 capable receiver: on
E-AC3 capable receiver: off
DTS capable receiver: on
TrueHD capable receiver: off
DTS-HD capable receiver: off
DSP: off

Debug logs uploaded here:
https://paste.osmc.tv/ajiwupilew

Please let me know if I can provide more info or test a fix! For now, I’m reverting to 2.1 audio, which works fine.

Thanks,
Alex

Hello Alex,

For now, you can run these commands:

sudo wget https://raw.githubusercontent.com/osmc/osmc/a02369fad9c3adfde5a4c5024eaf6dd7af56a3b0/package/vero3-userland-osmc/files/usr/share/alsa/cards/AML-M8AUDIO.conf -O /usr/share/alsa/cards/AML-M8AUDIO.conf
sudo reboot

Apologies for the inconvenience here. This will get you up and running promptly.

Thanks for your logs. I’ll follow up in further detail shortly.

Sam

@f0o I understand that you’re happy to troubleshoot things a bit, so I’ll get in touch with you directly shortly so we can work on a couple of improvements

Sam

@alex_so23fg8 You can now update via My OSMC -> Updater to resolve this problem.

Sam

Yep - looks good now. Thanks for the quick turnaround sam!

Alex

If anyone wants to test for this issue, I have uploaded 5.1 test files here in various formats that will announce the channel that it’s supposed to be coming from (“left front,” “right rear” etc): Multichannel audio incorrectly mapped

I’ve tried a few of these files with the following configuration:

Audio settings are: 7.1 channels, stereo upmix disabled, full pass-through enabled and DSP disabled.
AMP is set for Direct so its not doing any signal processing and I have a 3.1 speaker configuration.

With the September release AML-M8AUDIO.conf (793k) are providing FR/RS on FR, FL/LS on FL and C on C.

WIth the rolled back configuration file above (1534k) the surround51.flac is putting C on FL+FR, rather than C, but the DSP & AAC files are properly putting C on C.

One thing I’m curious about is why I’m getting surround channels on my front speakers. With audio set to 7.1 and my AMP on direct, I shouldn’t get any surround content, should I? I ran these tests on my libreElec Intel NUC and I’m also getting surround on the front channels there, so not sure if this is Kodi or my AMP down mixing them.

I’d check the amp there if you see similar results on another platform.

Sam

Ha! I tried something with my amp almost immediately after I posted that. Sure enough, with surround set to none, it was puttng those signals on the front speakers. Now that it thinks I have surround speakers, the DTS/AAC test files no longer do this. Its persisting with the surround51.flac file tho - so that’s curious.

I’ve been using this amp for 5 years w/o noticing its direct mode is not all that direct… and all this time I’ve been blaming muddled movie dialogue on progressive hearing damage I sustained at a punk rock show 15 years ago. lol