September update breaks 5.1 Audio


I’ve seen this issue before in the forums, like months ago, so this is a potential duplicate. I sadly can’t find the thread anymore.

The gist is that after the September update, 5.1 audio isn’t delivered on all channels. As a consequence most audiotracks are not available anymore and merely the background noise (rear mostly) is present and also send to the front speakers.

I use Optical sound and my sound system is not smart enough to tell me which channels have input.

However, what does work is Stereo including Upmix.

I tried changing the audio-settings and also disable passthrough but no luck.

I can deliver logs tomorrow.

For a quick and dirty fix, does anybody have the old vero3-mediacenter-osmc.deb and it’s dependencies on a mirror ?

The change likely causing the change in behaviour isn’t made in Kodi, it’s made here: [package] [vero3-userland-osmc] ALSA: Update AML-M8AUDIO.conf · osmc/osmc@2b2b23d · GitHub.

The change was to fix issues reported here: Multichannel audio incorrectly mapped - #50 by sam_nazarko

Can you explain whether you’re using passthrough and post some logs?


Hi Sam,

thanks for the blazing fast answer and even with the fix!

Turns out it didnt passthrough in the end because it was a different codec. At which point it should’ve been transcoded by kodi, right?
I use the default audio device AML+PCM, set channels to 5.1 and choosed Optimized as option. But even Fixed didnt really do anything.

On the good news however, I revered /usr/share/alsa/cards/AML-M8AUDIO.conf to
commit a02369fad9c3adfde5a4c5024eaf6dd7af56a3b0 and after a swift reboot it worked flawless again.

$Wife is sadly using the device right now and it’s her time of the month again, I’d rather not poke the dragon with fiddling around the TV again :wink:

I’ll switch to debug tomorrow and reset the AML-M8AUDIO.conf to the latest version for your logs :slight_smile:

As always, keep up the good work and thank you very much :slight_smile:

Can I just add - I’ve been having problems on my 2 vero 4k’s since updating to the August update
Audio disappears but only on some Channels
I should have learned my lesson after a previous update destroyed the bluetooth audio - but I got rid of (given up on) that and use analogue- I made it a rule not to update as update seems to bring more grief. As it is, this household is a whisker away from junking the whole lot and paying for a Sky subscription…Arghhh (sympathise with the previous ‘wife’ comment)
I’ve gone back to the May and June installations respectively and the loss of audio problem has disappeared

FWIW I am not using passthrough or any multichannel
2 channels - output optimised (changing that made no difference) no stereo upmix resample quality medium or basic and no DSP processing.

I have 2 cards TBS manufactured - one a quad S2 the other a dual T2
DVBlink is my server end
All comments apply to live streams and seem to apply to Satellite channels only
I have uploaded a debug log but that was after reverting to May install. and is related to a different problem where on reboot I get DVBLink could not be loaded error 2000 or DVblink seems to load but sticks at 0% until one clears the EPG data.
But the debug log might retain something of the old errors?? maybe not as it was a clean install

I realise that the August and September issues possibly solve the DVBlink loading sticking but I simply do not have the energy/will/stamina to reinstall the latest and be faced with the audio problem and then upload another log -

I’ve just about got OSMC working and am not prepared (for the sake of my sanity and marital status) to install anything else which might mess it up

@sam_nazarko I know you do your best and that clearly is a lot more than most - you seem to be ever present - all plaudits to you for that but if every update of OSMC brings a separate new problem then whats the future?
You cannot have a situation where you first discover a problem when you sit down to watch something. On the other hand it is impractical to expect every user to test every channel each time a new update happens.

A lot of issues arise from the fact that different people have vastly different set ups and there are third party bits. Often enough it is not OSMC but the third party stuff - For example in the 9 hours I spent yesterday trying to clean and stabilise my set up, I got ‘internal error’ on DVBlink more that 12 times - no way of knowing what and only a reboot solved it.
When I have more time I’ll try and post about some of the peculiarities, I’ve discovered, of using it with live TV ad the equally strange DVBlink server. That’s if this household hasn’t reached the end of the road.


Hi John,

I understand your frustration but I feel like mentioning that you shouldn’t make it Sam’s issue.

In the end this is an Open Source project and as such it is a community effort where every single member, from core developer to end user, is a part of.

We can only get OSMC stable with self-engagement. Beta-testers are a key factor here, many larger projects have whole Quality Assurance teams who’s sole purpose is to deal with this. Even popularity contests or surveys are a key element in discovering the usage/setups of the end users so that the QA team can test for those things.

I speak out of own experience, being involved in multiple Open Source projects. We are only as good as the community around us.

All this being said, perhaps maintaining 4 (?) platforms is a bit much for a handful of volunteers. I’d suggest building up a QA team to test releases prior availability to the general public. Even make the QA Team open so that anyone can join and report in, the only requirement I’d make is to have an account here or on IRC and fill out a brief detail about one’s setup. This also needs a simple opt-in/out option for the end-users.

This would help us all identifying these issues before they it upstream.

This has gotten awfully off-topic. Apologies. Just my 2 cents on the future/stability concerns.

Hi @f0o
your input is welcomed and very measured
I was not ‘blaming’ Sam - for whom I have great respect - he does a great job of seemingly being in two places at once - but he is a kingpin.
I was just speculating about where OSMC is going if new updates break it. To expand out of ‘geekdom’ it has got to work ‘out of the box’ for non geeks. If ‘semi-geeks’ like me are giving up in frustration then something is wrong with the model

I am also familiar with teh value of communities and as I said I am happy to share my ‘gained’ knowledge of how to set up with the oddball DVBlink

I updated to the latest version and my audio is broken too.

After stopping video playback a lot of weird loud niose verry annoying.

Reboot helps but after stopping playback again loud noise.

My vero 4k is unusable at this moment.

Is there any chance to install the previous version (august update)

the ‘backgrade’ process is quite easy
take a back up of settings
download the OSMC installer - To create a bootable micro SD for your PI or Vero, for example, I downloaded the windows installer and ran it on a Win10 laptop.
This first asks you what language, and what machine you want to install on (e.g. Raspberry pi VEro 4k etc ) on next screen you can select which version. So here you can select an older version to do a backgrade.
I have found the June version to be best for my set up with vero 4k and DVBlink

The last screen asks where you want to install (this will presumable be a micro SD in an adapter in the SD slot of your PC. Useful to have formatted this first

FWIW if you are running on a high resolution screen on your PC (mine is 3200x1800) the drop down boxes of the OSMC installer do not display properly. You almost have to guess at the options being offered

Once OSMC installer announces it has finished put the micro SD into the Vero or PI and reboot
It will be like a full reinstall and you’ll have to reselect all your options but (though I’ve not done it myself) I beleive you can restore the said back up providing you saved it to someexternal or network place
Do not of course then accept automatic upgrades :wink:

Hope that helps

Post Script - I also have two rasp Pi’s in the network running OSMC - the missing audio does not occur on them even though they have the August update - haven’t dared try the September one

Hi John,

First, I’d like to just say that I can’t fix problems that I’m not made aware of.

In August, I see that you posted about a Bluetooth streaming issue. Bluetooth however is still experimental and that’s why we don’t yet include it in OSMC out of the box. There is a slight risk that it won’t function as expected sometimes; and it isn’t regression tested fully across updates at this time because some further changes are planned.

I wouldn’t recommend basing your decision not to update OSMC on an experimental package.

Can you confirm whether your audio issue is still present in the September version of OSMC? There were a few audio fixes to fix a couple of problems introduced in the July update when we enabled Atmos and 192Khz support. The main problems introduced here were an incorrect channel mapping for LPCM and muted channels. I understand that this is now fixed.

I didn’t find a post from you about DVBLink issues, so didn’t know that you were afflicted with this problem. There were some improvements to Live TV playback in the September update, and the reports have been quite positive.

Obviously we want to avoid regressions; but they are inevitable. In the unlikely event they do happen we try and fix things quickly. For example, there was a disk automounting issue last night on Raspberry Pi devices; but this was resolved within twenty minutes and made available to users within half an hour.

This suggests that there might be a problem with your DVBLink backend here; but I am not the best person to help resolve that. The DVBLink forums might help you with that one.

We effectively have this in the form of the staging repository; which we often suggest people use to test immediate fixes. I’m aware that there are some people using this test repository as a daily driver.

All of the updates that we release have been tested by some users before their release. You can find notes on the audio changes in the thread I linked to in my previous post.


I haven’t had a report of this yet.

Can you post a screenshot of your audio settings as well as briefly describe your setup (whether or not you use passthrough; and if so; what formats your receiver supports).

It’s not practical to downgrade as the solution will never be found; and it’s likely that we can resolve the problem more quickly than a downgrade.


Hi Marciano,

I had a similar issue a couple weeks back where I suddenly started getting horrible crackling from the UI sounds after video playback ended. I eventually tracked it down to an HDMI cable that had just barely been dislodged from the Vero. Try re-seating your cable to see if that helps.

Is the repo apt-get’able ? If so, do you mind sharing me the sources.list ? :slight_smile:

It’s written in many many threads
deb jessie-devel main

NB: when we move to Stretch, it will become stretch-devel.
The repo is 1:1 with stable at the moment as we just pushed an update


1 Like

Thanks Sam,

At the momentt i’m not able to post a screenshot of my audio settings i’ll do that later in this evening.

But i have every option in passtrough enabled.
True HD

By channels i have 5.1 and stereo upmix is enabled too.
My receiver supports almost every format except DTS:X and dolby atmos.

If needed i can provide som logs.


Okay – and when you experience the loud noise, is it only occurring when playing content that is being passed through?

Yes it is i didn’t try with passtrough disabled

I realise you cannot sort something you dont know about but on the basis of 20 years with some 30 developers (what luxury!) and a few hundred customers I came to realise there are always minor glitches that one is not made aware of - The fact that we were not told still didn’t stop people giving us less than 5 stars :wink: but that’s life. the DVBlink issue is a case in point. In all of my setups (Vero and Pi) I have managed to discover a workaround by either disabling and reenabling the PVR addon or by clearing the EPg database. Having found a getaround there was less urgency to file a bug - that’s what happens - one lives with shortcomings… but as I am intimating you cant expect non geeks to find such workarounds

Oh and yes I realise that many of my frustrations have been about getting DVBlink to work without pixellation or blue screens saying all 6 tuners in use (not),completely losing the epg etc etc.

Thing is, though, DVBlink has not changed in 12 months.

At least I now have a stable working operation on the June edition of OSMC and the latest 12 month old DVBLink

Anyway I’ve installed the September OSMC update on one PI and DVBlink add-on steadfastly refuses to load - the same error 2000. the logs are uploaded at /ekumerofuj
The workaround that works on previous editions does not work for me on the September update for Pi- I haven’t yet checked about the missing audio on the Vero 4ks yet - I am completely out of free time.


Hi John

I understand that sometimes users work around things without telling you. We sometimes get a few users in and watch how they use OSMC to see if we have missed things from a usability perspective sometimes.

In this case however, it seems that the issue might exist in your DVBLink setup, particularly if the problem is occurring on OSMC across different platforms (Pi and Vero).

There have been several updates to Kodi’s DVBLink add-on this year. Unfortunately we don’t develop or maintain the DVBLink add-on, so I would recommend you ask on their forums.

My understanding is that there are a good number of DVBLink users enjoying PVR with the latest version of OSMC.

If there’s anything you need help with that is directly related to OSMC please give me a shout, or send me a PM if you’d rather take a quick call and discuss this over the phone.


I’m also seeing the error as described by f0o, although I’m using HDMI rather than optical.

This has started as of updating to latest today.

Relevant (or maybe not relevant, IANAE) settings:
Audio output device: AML-M8AUDIO, HDMI
Channels: 5.1
Output configuration: optimized
Stereo upmix: on
Allow passthrough: on
AC3 capable receiver: on
E-AC3 capable receiver: off
DTS capable receiver: on
TrueHD capable receiver: off
DTS-HD capable receiver: off
DSP: off

Debug logs uploaded here:

Please let me know if I can provide more info or test a fix! For now, I’m reverting to 2.1 audio, which works fine.