OSMC's September update is here - OSMC

OSMC's September update is ready with a wide range of improvements and fixes to keep your OSMC device running in tip-top shape.

This is a companion discussion topic for the original entry at https://osmc.tv/2017/10/osmcs-september-update-is-here-2/

This update seems to have bricked my system. When I was upgrading, the system showed an error about Bluetooth 5.23 and said that I should report it. My system has entered a boot loop that shows a sad face every time it tries to reboot. I tried sshing in with the osmc user and logging in using the console. The system would not even allow me to enter a password before it said authentication failed. I suspect that I will need to reformat and reinstall.

Not sure what happened, but this update caused me to loose all my external drives. They don’t even show up anymore.

There haven’t been any changes to Bluetooth in this update.
You reported this issue on the forum before OSMC’s September update was released; so I suspect that this update hasn’t caused the problem.

As explained in the thread, your SD card seems to have experienced some corruption.

Some SD cards are not genuine or have a lower capacity than advertised. Some simply fail over time.

Symptoms of SD cards not working correctly are:

  • Read-only behaviour, or changes made not persisting
  • A filesystem corruption error

Symptoms of counterfeit SD cards are:

  • Writing works until a certain filesystem size is reached, thereafter, writes seem to cause issues where existing data is lost or newly written data is not preserved.
  • SD card fails after a short amount of time.

Counterfeit cards are usually found on Amazon and eBay.

SD cards have a limited lifespan. I recommend you change SD card and suspect that issues will no longer persist with a good card. If you would like to be a good quality SD card purpose manufactured for OSMC, then you can find one in the Store.

This should be troubleshooted in a separate thread.

1 Like

Will do, following the thread: RPI3 not mounting drives after September update - #5 by sam_nazarko

This should now be fixed. Please try updating again in ten minutes.

You can do this manually by reading Keeping your OSMC system up to date - General - OSMC.

Sorry for the inconvenience


I will reformat the SD card, and try reinstalling again. If that does not work, I’ll buy a new card. Regardless, running into an error saying (if memory serves me right): “error installing Bluetooth 5.23… Please report the error in the OSMC forums”, is a deceptive error if the error is a file system error. I guess the error would make sense if for some reason the drive was corrupted and the corruption just happened while the Bluetooth was being installed.

There is no simple way to detect filesystem errors due to the very nature of the problem

You probably had filesystem corruption for a period of time and it only came to light when you performed an update

@sam_nazarko is a Kernel bump for Blueborne Patch (CVE-2017-1000251) coming ?

In the next update, yes.

Works well as far as I can tell.

Update installs ok for me, but keeps telling me there’s another upgrade and asking if I want to install it. Unless the latest update isnt Septemeber 2017-09-01 as shwon on thr OSMC app.

There were two minor corrections being distributed in the last two days therefore you would see the remark. But if you do it today it should not show up again (unless another urgent fix).

Same I keep having « update available ».
When running sudo apt-get update / sudo apt-get dist-upgrade there is no package to upgrade :frowning:

If the MyOSMC addon thinks there is an upgrade available, you can only clear it by forcing a manual upgrade via the addon to clear it.

Already done but still have the message « update available »

Did you check via My OSMC, or just run the CLI method of updating?

I tried both

Did you reboot afterwards? If so – start a forum post with logs. The announcement thread isn’t really used for troubleshooting.