OSMC's September update is here with Debian 11 (Bullseye) - OSMC

Thanks for all the effort porting OSMC to Debian Bullseye.

The upgrade on my RPi 4B went smoothly. It took about an hour which I consider normal given that all the underlying OS resources needed to be upgraded. The only thing I had to smooth out manually were the python3 modules. Obviously, python3 was purged and reinstalled completely so that I had to reinstall some modules with pip3.

2 Likes

Does this release include hardware deinterlacing of live TV on the Raspberry Pi ?

No - it doesn’t.

The update seems to be working fine for me on my Vero 4K+ so far.

It did an odd initial update with a reboot where it sat booting for a bit and timed out trying to sync network time, but then it booted into the March version, which I already had on there. Then forcing another update it seemed to do the needful.

No problems for me on my Vero 4K. And in bonus, the multiple CEC bugs with my LG Oled TV are fixed !
Nice work

Thanks!
I see /lib/modules/4.9.269-9-osmc/kernel/net/wireguard/wireguard.ko on my OSMC, and it’s in the osmc-openlinux-4.9 branch, but not in master branch.
How do master and osmc-openlinux-4.9 relate?

The 4.9 branch is the version we are shipping.

Run a manual update twice but it doesn’t find the latest build.

Hi,

I would create a new topic with some logs please:

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

I have a RPi 4 which i use as a server and a RPi 3 as a client. I’m accessing the files on the client using NFS. I have an external HDD mounted on the server with the files.
I’ve been having this setup and everything was working fine until i updated OSMC on both the devices. Now on the client, it cannot open the mounted path from the server. On the server everything is working alright.

I tried ls -lah /mnt/ on the client and i’m getting:

ls: cannot access '/mnt/HDD': No such file or directory
total 8.0K
drwxr-xr-x  3 root root 4.0K Oct 26  2021 .
drwxr-xr-x 20 root root 4.0K Sep 19 23:48 ..
d?????????  ? ?    ?       ?            ? HDD

I also tried following the “OSMC as a server” guide here again and everything seemed fine until i ran the exportfs -a command: (note that i’ve ran everything before when i did the setup, more than a year ago)

exportfs: could not open /var/lib/nfs/.etab.lock for locking: errno 13 (Permission denied)
exportfs: could not open /var/lib/nfs/.etab.lock for locking: errno 13 (Permission denied)
exportfs: can't lock /var/lib/nfs/etab for writing

and with sudo:

exportfs: /mnt/HDD does not support NFS export

Can somebody help me what to do next?

Update: I restored a backup of the server sd card i made just before updating OSMC, and the files are accessible from the client again. I would still like to update OSMC though.

Please make a new thread in the appropriate subforum with complete logs. Support requests are not conducted here in the version release announcement thread.