Overlay logo top right corner

First of all i must give thanks for all your work, is really awesome!

I’ve a question about the new update, i’ve update my OSMC installation to the last one (aprils 2016 update) on my Raspberry PI 3 this morning. After doing this, appeared a box in the top right corner like a color selector and i dont know what is this and how to remove because while i’m watching any video for example on Youtube, navigtate in OSMC menu, etc… still there

¿How can i remove this?, ¿what this mean?

Thanks for all!

If it looks like a rainbow, it means your power supply isn’t sufficient. See Wiki - OSMC for details.

Oh! thank you! im using a external power supply that is the requerimments of RPI3, how is possible that yesterday i dont have this rainbow and after update i got it?

Thank you for all!

Make sure you have a good powersocket connection and don’t use any powerhungry accessoires like external HDDs without own powersource, a lot of usb stuff etc.

Edit: What exact powersupply are you using? Should be at least 2A@5V and not drop below 5V under load, like many phone/ipad chargers do.

Well many reasons are possible (bad connect) but one possibility is that the update made Bluetooth working means one more chip to power on

I use one power supply USB from a mobile phone, exactly Sony with:

TYPE: AC-0030-BV
INPUT: 100-240VAT ~ 150mA 50-60Hz
OUTPUT: 5.0VDC - 850mA

I have BT disabled after the update. I’ve connected my RPI3 directly to my Samsung TV USB that have 5.0 too and the rainbow appear but blinking slowly


That is not good enough. Needs to be at least 2000mA.

1 Like

I’ll buy a new one that have 2000mA, thank for the support :)!

Same here with a good 2A power supply. Don’t have the issue with my other Pi (2), or with 2016.02 OSMC.

Edit : I’ve disabled pi3-disable-bt-overlay.dtb just before applying the update, can it be caused by BT enabled ?

I had this rainbow square appear this morning on a 2.4A supply. Turned out to be the power cable, I replaced with a shorter/chunkier one (the existing was long and thin) and it went away.

Curious how it hadn’t appeared before today though, maybe something in the kernel changed.

Saw this on one of our dev channels from popcornmix this morning…

I see a couple of reports of under-voltage warnings that have appeared this update. There was an issue in firmware a while back where the warnings would get lost after a hdmi mode change (quite possible on kodi boot). I think this is the first OSMC that contains the fix, so the new warning is correct, and the lack of warning before was incorrect.

I’m using the Rpi3 official power supply.

Never had any power issues since.

It provides 2.5amps.