P3 Chinese PS3 Clone

Hey all,

I got a couple of “P3” Chinese PS3 controller clones. I see that a lot of people have requests for help with PS3 controller set up with a bunch of answers, most of them quite old. This is the newest;

Did anyone ever get this working with OSMC, is there a way to install these retropi packages under OSMC?

I have tried to manually pair under CLI, but get the same error;

Pairing with a listed MAC-Address:
CHG Device 90:DD:5D:AF:ED:C8 Connected: yes
Failed to pair: org.bluez.Error.AuthentifictionFailed
CHG Device 90:DD:5D:AF:ED:C8 Connected: no

Any help would be great :slight_smile:

Found this;

1. Disable Bluetooth in osmc
2. Connect to Pi trough ssh
3. Don’t connect the PS3 controller yet
4. Evoke
Sudo sixpair
5. Connect the controller trough cable
6. After sync disconnect the cable and press Ps button
7. evoke
Sudo sixad --start
8. After some secs the controller syncs trough Bluetooth (it rumbles)
9. Ctrl-C to stop sixad
10. Install sixad to start at boot:
sudo sixad --boot-yes
11 reboot

If anyone knows this might work?

Also found RetOSMC. But it seems pretty old, not sure if its still a thing?

For anyone looking to get these clone controllers to work with OSMC, RetOSMC does the trick :slight_smile:

RetrOSMC is actively maintained and @hissingshark provides a lot of support on these forums.