Passwordless Samba share with smb-app-osmc?


I’ve installed the Samba app smb-app-osmc, and it works OK. But the idea is that anyone in the apartment should be able to have read/write access, without a password. At the moment it requires user “osmc” password “osmc”.

I see a lot of suggestions to use “security = share” and “guest account = nobody”, for example [SOLVED] Samba with guest (no password) and users (with password). But when I try that, not only can I not connect as a guest, I can’t connect at all (I’m connecting from a Macintosh).

This angry person makes it clear that this is NOT something you can just figure out by reading the manual and googling: file sharing - How to make Samba share to NOT ASK FOR PASSWORD - Server Fault. I really need a recipe known to work on OSMC. Can anyone help?

This is a freshly install of OSMC_TGT_rbp2_20170705.img on my Raspberry Pi 3.


Have you tried “guest account = osmc”?

Same result, unable to connect at all. In fact the guest account setting doesn’t seem to matter: as soon as I change security to “share”, that seems to break samba entirely.

Also note that the security setting is already in the stock config file. But the guest account is not, I had to add it.

Don’t set security to share then

That’s the setup I’ve got now. I can connect as osmc. But if security is not set to “share”, I can’t connect without a password. That’s what “share” means.

Will check on my system and update the thread


@matthew_exon, just took the default config (with security = user) and added to [osmc] section guest ok = yes and commented out # valid users = osmc
this allowed me to access the osmc share without password.

OK, I figured out my problem. I was actually sharing a USB drive, and it’s mounted as root. You can only guest share a directory if it is owned by the configured “guest account”. I instead shared a subdirectory owned by osmc and it worked fine.


If you use the great automount/autoshare feature USB drives will be mounted as osmc :wink: