Pause menu staying on screen

When I pause a video the menu sometimes stays on screen and I can’t get it off screen without first stopping the video. This is often accompanied by severe lag navigating the on screen menu.

This has been an issue since the May builds, around the same time issues with stuttering playback occured.

I have a vero 2 and have tried re-installing OSMC a few times now without joy.

To get a better understanding of the problem you are experiencing we need more information, including logs from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

Logs: http://paste.osmc.io/oropogosac

No one else seeing this?

I’m getting this almost every time now, when pausing the menu remains on screen.

This latest time (4th time in a single film) after stopping the video and restarting it osmc produces a graphic while loading the video (circular dots), it remained on screen and the device didnt respond to touch. I had to reboot via ssh.

I’ve provided logs, assistamce would be appreciated.

Not seeing this.

Do you have a clip which can produce this issue?

I have checked your log, and I don’t see anything obvious. With that said, I have limited data so couldn’t check this as thoroughly as I would have liked to

Sam

Hi Sam, all videos, have fully reset device and issue is still happening.

At first I thought it was the confluence skin, but it does it even with the default osmc skin.

i would provide a screen shot but it looks exactly like the pause menu is remaining on screen while playback is ongoing.

Are you playing back from a local source?
What kind of content are you playing?
Can you upload a sample clip to produce this issue?

A screenshot would also help. How are you pausing the content? If you press OK, then pause, and then press play, the menu will remain on screen until you press Back.

Hi Sam,

Yes, playing back from a local source (USB HDD formatted to ext4), it happens whether I’m playing back hi-def, standard-def, 5.1 or 2.0, xvid, x264, or mpeg2 - any video file I’ve been able to try.

I could upload a sample clip, but it would be just as easy for any clip you have to try that, if you want the best thing I can do is upload a clip of the problem happening? Would you like me to do that?

Cheers,

Martin

The problem is I haven’t seen this problem with any clip that I have tried.

A clip of the problem occurring, and what you are pressing on your remote would be quite helpful. I don’t think I’ll be able to view it until I get back, but it might give someone else some clues.

Sam

Turns out it was caused by an addon that I installed called watchdog. All sorted now

Great to hear! Back to the beach for me :wink:

Unfortunately I spoke too soon, I’ve now disabled all addons and this is still happening. I’ll try and get a video uploaded Asap.

Hi guys!
I’ve the same annoying issue every time I start a movie. Sometimes the circle dots disappear after a few seconds, sometimes they stay on the screen for minutes!
That’s frustrating!
Tried almost everything (reboot, play directly from usb drive or nas…).
I’ve installed yahoo weather plugin, YouTube plugin, simple iptv.
My nas (Apple Time Capsule with external usb hdd) is attached by lan cable to a 100mbit switch and then to the rpi3. The smb share is configured by fstab with persistent mount point.
Someone can help?
Thanks!

Which skin are you using?

Can you explain what you mean by circle dots?

Also make sure you are on the latest version of OSMC.

Hi Sam!
I use the default OSMC skin.
The “spinning dots” are those withe dots that runs in circle when the movie is “buffering”…
I’m on the latest update (the issue is annoying me from late may)…and now I’ve found the matter…it is one of the four port of the switch!!!

I’ve tried to attach the rpi3 directly to the Airport Router (5/6 lan meters cable utp cat5)…and the issue is disappeared. Now the “spinning dots” disappear in less than a second…I think it is normal.

I’ve reattached the rpi3 to the switch using another lan port…and the issue is gone…
Tried the “first” port and the issue is now present…

Now I think one port of the switch is defective…it can’t support the correct stream buffer…

Is there any piece of sw to test effective LAN or WiFi speed (via ssh) ?

Thanks a lot!

EDIT: the issue is still here!!! with or without the switch…in this condition the CEC is no responding, only the Kodi Remote or the Usb Keyboard

EDIT2: It seems that without the switch is almost gone (only a couple of seconds), I’ve made a short clip to document the issue…how can I post it?

Hi – the issue reported here is for Vero 2. Do you experience this problem on a Vero 2 as well? If not, I kindly ask you start a new thread. The issue may be a Kodi bug, but I’d still like to keep the posts separate so that @martin_osmc gets the support he needs

Sam

Sorry Sam my mistake. I’ve a Rpi3, ok I’ll post in the right section.