PCM2704 - Dolby Digital 5.1 passthrough not working on B+

Hi folks!

I just purchased and connected an external PCM2704 USB Soundcard. It´s getting recognized as “ALSA USB Audio DAC” with SPDIF or analogue output and sound works in menu and for music. So far so good.

Problem is:
Movies (mostly mkv) with AC3 sound don´t have sound, those with DTS work perfect. My audio receiver doesn´t get any DD signal (led stays off) neither through coax or optical toslink. For DTS no problem, receiver switches to DTS mode.

Can this be fixed or is it related to some maybe licence problem??

I also noticed that after stopping playback of a movie with DTS sound the soundcard/osmc does not switch back to “stereo mode” but stays in DTS mode (receiver led blinks) so no interface sounds come through. Same as when playing a movie with DD after one with DTS.
I was able to get around this by setting audio alive from 1 minute to off - but maybe that information is useful.

Working on:
Raspberry Pi B+
OSMC 2016.10-2, linux kernel 4.4.27-2-osmc

Greetings
CaseSensitive

Rly? No support within seven days?? :frowning:

Saving @ActionA the trouble:[quote=“ActionA”]
To get a better understanding of the problem you are experiencing we need more information, including logs from you. Our wiki contains detailed steps for providing the relevant info we need to help you.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request
[/quote]

2 Likes

Thanks for your reply and the hints. I was looking for a solution in this forum and on the internet also. Thought not that my provided information is too less. Hereby the logs and more information about the video files:

OSMC logs:
http://paste.osmc.io/cinenetuha

Mediainfo of an example movie file with DD that does not work:
http://paste.osmc.io/sasavilasa.coffee

Thx so long =)

Any updates on this? :frowning:

What you need is a passthrough mode to be supported by the chip and its driver, it is not.
Only some cards can do it, see USB-Audio.conf from alsa libs.

1 Like

Thanks for this prudy!
Meantime I did a “workaround” for this by buying another receiver with HDMI.