Performed the recent update and now wireless will not work

I have an OSMC box that has worked great up jubilee an update tonight. Was working fine, performed the update and now wireless networks will not display and the box remains offline. I have tried restoring from a backup, plugging into wired to check for any more updates but all to no avail.

Please help.

We need to see what’s happening on the box.

The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

It won’t upload the logs, says URL error even though I’m connected with a wire. I don’t have an SD card right now so I will have to wait to upload them. Oh well.

Can you SSH to the device?

Disconnect the cable. Reboot the device twice. Try to connect to wifi. Then connect the cable and try to upload logs again.

If you are able to ssh in while connected wired, try this: Warning: you will need to enter your network credentials after doing this!

$ sudo rm -rf /var/lib/connman/wifi_*

And try connecting again.

I’ll try that, thank you.