Peripherals not working | Raspberry Pi Zero

So I just installed this version of osmc: OSMC_TGT_rbp1_20190105.img (and plugged the sd card straight in), on my rp0 and any peripherals I plug in don’t work (wireless keyboard, gamepad, usb keyboard, usb mouse). I am stuck on the setup screen and nothing seems to have worked. I have been searching for days in the forum but nothing has worked.
I have had this issue when I previously installed osmc and gave up on it. Any ideas on what I could do? Or what info I can provide you to help me?

I would suspect power. What kind of power supply are you using? A phone charger or an official power supply?

a xiaomi power brick and cable it’s 5V/2A. I didn’t have this problem with other operating systems though.

I tried a 5.1V/2.4A source but it still doesn’t work.


A quick google search reports results of fast charger, which means it will not constantly be providing 2A. Best bet is an official pi psu.

Is this another charger? Please provide more details make and model?

Thanks Tom.

it’s the xiaomi powerbank 2c


Which again is used for charging devices. You will have more success with an official power supply.


I’ll order one up and tell you what happens

1 Like

simple way to know if there is an issue, the way to do this is

cat /sys/devices/platform/soc/soc:firmware/get_throttled

if it replies with anything else then 0 there could be potential issues with the charger also dmesg will show entry logs from the kernel if under runs are detected.

1 Like

where do I enter this command?

1 Like

via ssh use the link tim supplied. there is a good reason why any old charger isnt viable for rpi sadly this is lost for users since all they see is the micro usb slot

1 Like

I am stuck in the setup screen, so I can’t setup an internet connection to connect via ssh

The Power Supply just arrived, it still isn’t working.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

As I said nothing is responding I can’t enter any menu or do anything


Could you please provide a photo of this?

How are you preparing the sd card? Are you using the OSMC installer?

Thanks Tom.

I tried flashing the img both with etcher and win32diskimager

I am going to provide you with an image in 1 minute

I am just stuck on this screen and nothing happens when I press any button