Permanent IP for new Vero

So my new Vero 4K arrived today, and I am thinking about how to set it up.
First of all - how do I assign a fixed IP address?
Then - I haven’t done a backup of my library and the raspberry pi settings. Would there be any disadvantage with starting fresh with the Vero?
I would mount via fstab and need to configure the sources, ok. Will I need the buffer tweaks via advanced settings with the Vero?

You can do it either in the router, using DHCP, which is what I’d recommend, or you can do it via My OSMC → Network.

If using DHCP on the router, you would assign a fixed IP address to the Vero4K’s MAC address.

Startin with a fresh install will ensure that any legacy “cruft” isn’t carried forward to the new device.

It would depend on what you’re trying to play. There’s no hard and fast rule.

It won’t hurt. It looks like these settings will be in the next update. Please try them out:


FYI - the tweaks are only required if you use ta WiFi link. Using an Ethernet link, no tweaking is required. However, if you have more than one device to be fed by your NAS - then you need to make sure the NAS delivers the data fast enough to all devices.

This is not necessarily true, especially with high bitrate 4k/HDR/HD audio media. We’ve seen plenty of examples of this on this forum.

Yes. That may be correct, but only required if the NAS is crap and has a low-power CPU IMHO.
All my issues with trhe Vero 4k have gone away since I have replaced my NAS with a HP Microserver gen8 with a Xeon CPU and 16GB Ram inside + Raid 5 and 2x1Gbps Ethernet Bonding… :} and fine-tuned NFS server on it.

That’s not true. Some high bitrate 4K content can burst over what a 100Mb connection can handle.

Wow, I’d love a setup like that as my NAS!

Heh. That may be true. But I don’t know of any Movie provider streaming at that speed :} Hence, for me it is not really relevant :wink:

That is my beast BTW:
The funnyt thing is, the bare system came with a 2.2Ghz Celeron CPU and 2GB of Ram - and I paid 180 euro for that. Only upgraded the CPU and RAM, and added 4x3TB Disks. :} Nice beast!

OK, for a start I just switched it on using WiFi and DHCP to see if it works fine. All good, speedy, October update went through without problems. No time to create the new account on my NAS yet, so no library yet.
I’ll think I’ll write a bigger first impressions post in the general discussions section when all is set up and running (and when I have a proper keyboard available :slight_smile:).


I am trying to SSH into the Vero - but only get an error message.
I am using SmarTTY, and used it yesterday to SSH into the Raspi.
Now, trying to open a new connection , it says:

What can I do?

Try using Putty or updating your client.


Quickest answer EVER :slight_smile:

Well, I connected to the Raspi yesterday - is anything different with the Vero?
What does this failure points to? Sth to do with the ssh keys? But they should be stored for each connection if I understood it right?

EDIT: putty worked. But I like smartty, so still would like to resolve that problem.

Address the issue with their developers then.

Is the raspi running the same version of OSMC?
Generally they both should be the same if they have the same version.

And if we haven’t had SSH config issues.

Worth checking sshd_config on both devices.

Guys, thanks for your quick replies!!!
It seems this problem is not easily solved, and I like to get the vero running as my first priority.
As putty worked, I tried mounting via fstab and got some questions there, but posted them in the thread containing the fstab tutorial , sorry.

FYI, a new version of SmarTTY (v3.0) was released on 27 November 2017.

Thats the one I used yesterday … but thanks for the hint

Worth checking.

I did come across a forum post from 2016 here where someone says:

SmarTTY’s kex, cipher, and MAC support is antique, unfortunately.

I’d have hoped that this would have been rectified in the latest version.