Permanent red light and unbootable Vero 4K

In the last months I sometimes found my Vero 4K had a red light after some time (hours) unused (for example, if I watched some video after dinner, it sometimes had a red light in the morning). When the red light appeared the Vero wasn’t reachable via ssh and there was no video output, but just unplugging it and plugging it again (the old trick) “fixed” it.

Last Friday the light was red again, so I tried unplugging and plugging it again but it didn’t help anymore. The red light was permanent and the device didn’t boot. I searched on the forum and saw someone recommended leaving the device unplugged for some hours and then try again, I left it over 12 hours but still no luck.

I searched on the forum some more and noticed @sam_nazarko suggested to someone having the same problem to try with a different 5V 2A adapter, so I searched for one, tried it, and my Vero 4K worked again.

So this is Just to let you know that there’s another case of the red light problem and that it was solved with that solution.


Is the device warm to touch when this happens?

If the adapter is problematic, the device probably won’t power on at all. Does switching the adapter back reintroduce the problem?


The device is usually warm to touch, even when idle with a blue light. Not really hot, but definitely not cold.

Yes, if I switch back to use the original adapter, the Vero shows the red light again and it doesn’t boot.

If it doesn’t boot at all, then you may need a new adapter.
Out of curiosity, how long have you had the device? The odd power supply fails but usually this is fairly immediate.


I’ve had it since October 2017, so nearly 2 years (I even use it as a borgbackup server too to backup my other computers in hard disks connected to the Vero 4K, so it’s always on). it’s been just two or three months since I noticed the led could also turn red.

If you email with your address I can send you a new power supply. It’s better to use an official one from us that has been certified for use with the device.



Thanks! I’ll do so.

@antlarr does everything work fine for you now? I’m asking because after I started using the 4k along w/ borg and borgmatic for external HDDs I experienced the same thing. Currently - after many PTPs - the 4k works again… I’m just wondering …

Yes, after writing the message above I sent a mail to support and sam very kindly sent me a new power supply which has worked great since then (and I keep using borg on that system).

1 Like