Permanent "Update Available" Indication

I have requested an update to my Alpha 4 version running on a Pi 2, in the hope it might solve the mouse scrolling problem reported elsewhere. Howver in spite of a couple of reboot and a couple of power downs, I still have the “Update available” indication in the top LH corner of the screen. Have I missed something?


Please post your APT log - you can do this from the log uploader option in the Settings Addon.

Apologies for delay in replying.

Firstly, due to the mouse speed issue, doing anything is quite a challenge.

When I go to “Settings”, select “More”, “Add-Ons” appears, but disappears as soon as I try to move the mouse to it.

I eventually was able to get a list of Add-Ons under “OSMC Settings” or by using the keyboard rather than mouse, where I found “Kodi Log Uploader”. I installed this but there was no option to upload an “APT Log”. Can you please advise where I can locate this file using SSH?


The file is /var/log/apt/term.log

Thanks. Log file is as follows:

Log started: 2015-02-01 20:41:09
Log ended: 2015-02-01 20:46:10

Log started: 2015-02-01 20:46:21
Log ended: 2015-02-01 20:46:28

Log started: 2015-02-01 20:47:00
Log ended: 2015-02-01 20:48:27

Log started: 2015-02-01 20:48:39
Log ended: 2015-02-01 20:49:07

Log started: 2015-02-02 01:20:58
Log ended: 2015-02-02 01:20:58

Log started: 2015-02-02 01:21:07
Log ended: 2015-02-02 01:21:13

Log started: 2015-02-21 09:30:53
(Reading database … ^M(Reading database … 5%^M(Reading database … 10%^M(R$
Preparing to unpack …/bsdutils_1%3a2.25.2-5_armhf.deb …
Unpacking bsdutils (1:2.25.2-5) over (1:2.25.2-4.1) …

Edited to remove duplicate paste


Just tried:

from another post and now I get some updating action. However I then got an OSMC Update Error message:

Error installing :xmbc (2%3a132+dfsg1 -4)

Please report this on the OSMC forum.

Does that help explain what is going on?


xbmc dfsg is the standard Debian xbmc package which will most likely be extremely old and out of date, and will almost certainly conflict with the version of Kodi we provide in the rbp-mediacenter-osmc package.

We don’t ship this package so either you’ve installed it, or some other package you installed has pulled it in as a required dependency. Either way you want to remove it.

What packages did you install before this started happening ?

Had only (deliberately) installed Kodi Log Uploader, Mail, Keymap editor & MythTv add-ons. Will start again with a clean build to see if I get the problem again.


I’m thinking mythtv add-on might have pulled in the xbmc package, without knowing for sure though.

How do you uninstall these packages if they have been downloaded and installed?

I have the same issue on one of my p2. I have a blinking coloured rectangle on the top right corner. (I use the amber skin). I tried updating from the osmc settings gui, I tried also ssh sudo apt-get update; sudo apt-get upgrade and sudo apt-get update; sudo systemctl start manual-update. The rectangle just won’t dissapear.

Edit: Sorry, I found the answer, it isn’t the update notification, it is the power supply warning. I changed the usb cable and now it is ok.

1 Like

If you know the package name you can uninstall with:

sudo apt-get remove packagename

You can get a list of installed packages with

dpkg -l

So you could search for packages with xbmc in the name with:

dpkg -l | grep xmbc

When you try to uninstall it it may prompt to warn you that some other package requires this package and will also be uninstalled - take a note of this package and let us know - as this will be the package that asked for it to be installed in the first place.

We may need to make a change to our own mediacenter package to prevent this problem happening in the future.

I haven’t received the error updating but will check later tonight.

I’ll have a look for the XBMC packages and report back if I am affected,

Thanks for this information.

All good here - no XBMC packages.

Have started again from scratch, but this time changed the skin to Confluence to avoid the mouse problems, and have not (yet) seen a repetition of either of my problems. Will continue configuring as I want it to see if they recur.

@ DBMandrake - did the log file help at all?

Thanks for help, everyone.


I am having similar error message, mine says Error installing (unknown package).

And both history.log and term.log have a timestamp three weeks old, nothing about current problem there

Here are apt messages

Ign jessie Release
Ign jessie/main Translation-en_GB
Ign jessie/main Translation-en
Ign jessie/non-free Translation-en_GB
Ign jessie/non-free Translation-en
Ign jessie/main armhf Packages/DiffIndex
Get:1 jessie/main armhf Packages [103 B]
Get:2 jessie/main Translation-en_GB [103 B]
Get:3 jessie/main Translation-en [103 B]
Fetched 309 B in 2min 4s (2 B/s)
W: Failed to fetch gzip:/var/lib/apt/lists/partial/apt.osmc.tv_dists_jessie_main_i18n_Translation-en%5fGB.gz Invalid file format

W: Failed to fetch gzip:/var/lib/apt/lists/partial/apt.osmc.tv_dists_jessie_main_i18n_Translation-en.gz Invalid file format

W: Failed to fetch gzip:/var/lib/apt/lists/partial/apt.osmc.tv_dists_jessie_main_binary-armhf_Packages.gz Invalid file format

E: Some index files failed to download. They have been ignored, or old ones used instead.

Currently suffering DDos which has corrupted our mirrors as they have had incomplete transfers


1 Like

It was OK yesterday but this morning have the installing unknown package warning again.