Permanently Removing Local folders from file listing


When I navigate to music or video files the list includes local folders such as ROOT HOME etc.

I can “remove them safely” via the context menu, but they reappear later. Is there a way to remove these folders from the listing permanently?



Ensure File renaming and deletion is enabled here.

Thanks for your help :slight_smile:

I have file deleting enabled but prompted by your help, found that if I ‘safely removed’ them from the file manager the removal stuck.

Cheers :slight_smile:

Wait - are you really suggesting he should permanently delete /home and /root, like wiped from the filesystem?!
I guess that’s not what he wants (and nobody should), he just doesn’t want these folders to be shown and be available in Kodi’s listing… or am I getting this wrong? If not: I don’t know of a way to make Kodi not list the locally available folder structure.

Yes, appears I read the OP too quickly. Exactly where and what listing OP is speaking of would be helpful though. Sounds like OP simply hasn’t added the proper locations to his library where none of these items would be seen.

Thanks for your help so far :slight_smile:

Sorry, I should have made myself clear :slight_smile: and my ‘fix’ does not actually work so…

When I select Video/Files or Music/File or File Manager I see a list of local folders which include : ROOT, BOOT, RECOVERY DATA etc.

I have added a couple of sources :like a folder on NAS box and a local USB stick .

I would like to only see the NAS and USB, I’d like to remove from the source list those local folders.

Not possible. At least not easily, and you’ll be on your own to do so. This is Kodi behavior that OSMC has no control over.

Have you not added library sources? This way you can use Master Lock to prevent unwanted access to the File Manager and sources. If you want some media separate from other media, you should be doing this at the source level anyway.

I have been searching for the solution to this problem for a week now … without luck …
then I had an idea

I took a new sd card , copied noobs lite onto it and booted up my pi 3
When the OS selection came up I picked libreelec (it has kodi) and installed it
Did some basic KODI config after install and then went to VIDEO → File menu

:frowning: there were 2 folders already listed there , I right clicked on each of them and removed the source

Added in my network shares , rebooted my PI and only my network shares were now in the VIDEO → Files list

Problem solved

Hope this helps you

There is no reason why OSMC would behave any differently than LE in this respect. Please test for yourself before you come spouting off about how using something other than OSMC is the solution to anything.

Great to hear :slight_smile:

As long as you’ve found something that works for you, we’re happy.

Here are the steps I took exactly (might help work out what is different between OSMC and libreelec)
I did test it for myself here are my steps with numbers

  1. Got a brand new sd card formatted it then copied noobs lite files onto it (on my PC) , stuck card in my PI 3
  2. Booted up PI3 selected OSMC install and let it install OSMC
  3. Did some basic config stuff, timezone uk keyboard
  4. Went to VIDEO -> Files from main menu. Had 2 Folders already there RECOVERY and SETTINGS
  5. These cannot be removed / hidden like the first poster says you can unmount … but they return next reboot, they just wont feck off at all

SD card 2 has entered the game

  1. Got another brand new sd card formatted it then copied noobs lite files onto it (on my PC) , stuck card in my PI 3
  2. Booted up PI3 selected Libreelec install and let it install Libreelec
  3. Did some basic config stuff, timezone uk keyboard
  4. Went to VIDEO -> Files from main menu. Had 2 Folders already there Myvideos and movies (I think these were the names)
  5. Selected each in turn removed them and confirmed when it asked do you wish to remove from collection
  6. Rebooted PI3 , navigated to VIDEO -> Files and the removed folder were gone, then I added several NAS folders on which I had some videos
  7. Had a nice cup of tea and watched some firefly

I would call that a reasonable test, what do you think ?

Sure – as we say, if you’re happy, stick with LibreELEC. I’m glad it works for you.

‘RECOVERY’ and ‘SETTINGS’ seem like partitions from other NOOBS installations. I’ll add a rule to exclude these from automounting. Of course if you install OSMC directly from, you won’t experience this problem.

You have to disable automount them in /etc/fstab via SSH terminal.

Get partitions attributes with ‘blkid’

$ sudo blkid
/dev/mmcblk0p1: LABEL="RECOVERY" UUID="E381-1C3C" TYPE="vfat" PARTUUID="6f3f6fda-01"
/dev/mmcblk0p5: LABEL="SETTINGS" UUID="ee37a678-3ee9-4d0a-a6d1-894370631f2c" TYPE="ext4" PARTUUID="6f3f6fda-05"

Append their relevant values to /etc/fstab.
This will disable automount permanently.

$ sudo nano /etc/fstab
/dev/mmcblk0p1  /media/RECOVERY   vfat     noauto,noatime    0   0
/dev/mmcblk0p5  /media/SETTINGS   ext4     noauto,noatime    0   0
1 Like

Thanks for the useful replies guys really appreciate it

In the end I went with sam_nazarko advise and downloaded the OSMC image and wrote it to the SD card
I prefer OSMC to libreelec because it talks to my mediaportal server PC tuner cards better for some reason
(less glitches etc)

@rern , thanks for that tip

Discussed this with @DBMandrake today and he might come up with something over the weekend to make things more user friendly for NOOBS users.