Permission denied on Transmission and a new EXT4 pendrive

Hello everyone.

I use OSMC/Kodi on a Raspberry Pi B+ and some months ago suddenly I started to get the “Error: Unable to save resume file: Permission denied” deadly message on Transmission. I tried everything, changing permissions, re-creating download folders, formatting the external HD, even fully reinstalling the distro, but nothing. My filesystem is fuseblk/NTFS and I recently heard that this filesystem does´nt work well with Transmission, so today I tried to use a EXT4 pendrive as the download folder, but no luck either.

I would be very grateful if someone could lend me a helping hand.

Thanks a lot in advance and best regards.

Are you up to date with OSMC? There were some issues with mounting external hard drives and ensuring their permissions were valid for users, but this has long since been addressed.

CC @DBMandrake

An EXT4 drive by default only has permissions for root to write to it. So you need to change this:

sudo chmod a+rwx /media/mydrive

Where mydrive is the name your drive mounts with under /media.

Thanks a lot for the replies.

I’ve modified the permissions of the pendrive and now I can download. I have a little extra work due to the pendrive deleting the permissions everytime I plug it (if I try to reboot with the pendrive connected it gives me a kernel panic, so I unplug it everytime). But well, it’s not that annoying and I’m able to download at last!

I’ll make a copy of my system before updating, so I’ll do it tomorrow. Maybe this solves the reboot and the permissions issues as well.

Thank you very much again and best regards!

Can you provide a picture of this?


If you have a PI with only 2 usb ports put the boot device in the top usb port.

Thanks to both! :smile:

I´ll send you the pictures. Dilligaf, I have a 4 USB ports Raspberry Pi B+.

Best regards!

I don’t see why this would happen. Nothing is changing the permission of ext4 drives when they are connected.

Looking at your screen shot this is because you are using a USB install so when you have two USB drives connected the Kernel does not know which one is your root partition and chooses the wrong one. Please see the following post for the solution to that:

I´ll do that, thank you!