Phpmyadmin root login not possible

Hi there

I have followed the above guide and PHP my admin is up and running however, i can only login using my OSMC login i cant login using root so i can alter priverlages help.

Capture

I have attached picture of what is is showing me however i want the option of changing the priilleges

Thought i had but nope i have not

Is phpmyadmin running on the same system as the MySQL server? If not then you would need to give root the right for Hostname % on top of localhost. That you would have to do once from the system the mysql server is running on.

Php ia running on the same server as mariadb all of the users have % access and all privileges.

How would you do the above steps tonfollow please. I also try then import function and browse to the xml lib file but it says it isntoo big.

So is root access now working in phpmyadmin?

Please stop missing up topics! We have answered that question in the other thread. phpmyadmin is not the place to import the xml.

How do i see if phpadmin is working in root sorry i trying to work through this a step at a time. Is it as simple as logging in as root.

Phpmyadmin is in no way necessary to use a database server with Kodi/OSMC.

Bind it too your lanip instead of anywhere.

I know i prefer a gui view of data instead of lines of code

I have binding the address to 0.0.0.0
0 so change this to my lan static ip

So explain to us what is not working now with your setup.

After the initial setup, you should not need root access to the database. Just give the osmc user the same privileges that root has to the database.

This is what I have in my my.cnf

bind-address		= 0.0.0.0
skip-name-resolve

I suggest using those settings. If you try to bind to the lan addr, then you will have a problem if you change IPs in the future. Also, I’ve found the skip-name-resolve option to be very handy for speeding up access as it prevents Maria (or MySQL) from checking the hostname of every new connection.

Yes, you had been the one who wrote

While all of this would not influence the usage from within Kodi as long as your osmc user/password is working and you have configured that in Kodi respectively

I have moved your post to a new thread to avoid cluttering the Wiki entry

3 Likes

Hi there theres one thing i did not do which i will try tonight. I think after watching a you tube video i need to add an advanced setting xml on the server. As from a video i saw php admin will then show videos as a database item. If this does not work after that i will submit the steps i have taken encase something is missing.

Well not especially on the server but on every client (and your server in your case is also a client). You can use MyOSMC to configure the MySQL settings which then will be added to the advancedsettings.xml.

Write lets start from scratch. After i have followedd this guide and as i want to use the ras berry pi as a server client what is next as still not able to see movie database inside mysql

I’ve improved on them further by finding instructions on adding Apache, Python and phpmyadmin to administer the MySQL.

Install OSMC, add SSH & FTP servers

Make sure OSMC web server is not set to Port 80, change to 8080

sudo apt-get update
sudo apt-get dist-upgrade

sudo apt-get install apache2 -y (then browse to the Pi’s IP address to confirm)

sudo apt-get install php7.0 libapache2-mod-php7.0 -y
sudo apt-get install mysql-server php7.0-mysql -y

If not asked for a password for Mysql -
sudo mysql_secure_installation
Enter root password as ‘root’

sudo service apache2 restart

sudo mysql
create user ‘kodi’ identified by ‘kodi’; (this is the username I’ve historically used)
grant all on . to ‘kodi’;
flush privileges;
quit

sudo apt-get install python-mysqldb
sudo apt-get install phpmyadmin
select Apache 2 server, then say Yes to configure database with dbconfig-common
Enter root password

sudo nano /etc/apache2/apache2.conf
at the bottom add this line
Include /etc/phpmyadmin/apache.conf
Exit by Ctrl-X
sudo /etc/init.d/apache2 restart

Then check phpmyadmin is working by going to 192.168.1.xxx/phpmyadmin
login with kodi/kodi

sudo nano /etc/mysql/mariadb.conf.d/50-server.cnf
locate the line
bind-address = 127.0.0.1
and change the IP
bind-address = 0.0.0.0
Ctrl+X to exit, confirm you want to save the file

Restart the service
sudo service mysql restart

Did you configured Kodi to use the Database? Either via MyOSMC -> Network -> Mysql or by adding the information to advancedsettings.xml? And did you then imported your backup?
https://kodi.wiki/view/MySQL/Setting_up_Kodi