Phpmyadmin root login not possible

Why are you even installing phpMyAdmin? Unless you are planning on manually making changes to the database then there is no need for it. 99% of users just install mysql and forget it.

Thanks, yeah im goiing to retry and start from scratch , just our of curisoerty which is better xammp or lamp stack.

You are asking for an objective answer to a question that really can only have a subjective answer. The subject matter is also quite out of scope for this forum as well. You should be seeking general debian/linux support on more suitable forums if you want suitable answers.

I’m going to ask again: WHY do you need phpMyAdmin???

Just because i want to and so i can view the data nothing more than that.

now trying to log in on php my admin

CREATE USER ‘osmc’@’%’ IDENTIFIED BY ‘osmc’; not letting me in

We’re not going to give any assistance with phpmyadmin. If you need assistance with configuring your Kodi installation to point to MySQL, we’ll be happy to help.

Additionally, if you continue to clutter the MySQL wiki thread with off topic posts after having been asked not to do so twice previously and now a third time, your account will be suspended from making any posts for 3 days.

3 Likes

Hi

I have got mysql working next step is connecting my 2nd device to the server. I have copied over the sources and advanced settings xml to kodi on my tablet. When i open kodi up on the tablet i see all my movies but they wont play. It says movie no longer in libary do you want to remove. Is there my server is running samber and is on 192.168.1.118

Well I am actually not sure if we should continue this topic in this thread (which is totally not related to Kodi client connectivity to MYSQL) but let’s move on to get you out of our mind fast.
Provide full logs from your Vero so that we can review what might be wrong.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

You did a single file import of your library didn’t you? This would mean that all your media has its original file paths. Your original file paths were to a local disk at /media/Elements/... weren’t they? If so that is not a path that your tablet can access them at. You have to either change your sources so they are able to be accessed from the same file path on all machines (such as smb://ip/folder) or you have to put a path substitution in your advancedsettings.xml file that fixes the file path.

Hi there i read somewhere that the exporting of the libary was an option did not need to do that step unless you were migating your libary. Anyhow do you have an example advanced settings showing the substitute path. Pls

https://kodi.wiki/view/Path_substitution

You are migating (sic) your libary (sic) from a local path to something that can be accessed over a network.

Yes. There is a search function on this site and if you use it you will find that I have already shown two other people exactly how to do this in this last week.

1 Like

I have this so far

<?xml version="1.0" encoding="utf-8"?>
<advancedsettings>
	<videolibrary>
		<importwatchedstate>true</importwatchedstate>
		<importresumepoint>true</importresumepoint>
	</videolibrary>
	<videodatabase>
		<name>MyVideos</name>
		<host>192.168.1.118</host>
		<user>osmc</user>
		<pass>osmc</pass>
		<type>mysql</type>
		<port>3306</port>
	</videodatabase>
	<pathsubstitution>
  <substitute>
    <from>what would go here>
    <to>what would go here</to>
  </substitute>
 </pathsubstitution>
</advancedsettings>
</advancedsettings>

My SMB share rasberry pi is a follows

smb://192.168.1.000:445/Elements/movies/shared/movies

You have issues with your xml that have to be resolved or it will not load. If you are not familiar with what these rules are then please google it. You can also use an editor such as notepad++ that will help you in this regard.

As far as the “from” and “to” all your doing is saying when you find “this”, replace it with “that”. So if the paths in your database look like this…

/media/Elements/movies/moviename/moviename.mkv

Then your “from” is the part you need to replace which is “/media” and what it would need to get replaced with is “smb://a.valid.ip.address” so Kodi on the fly will make the path…

smb://a.valid.ip.address/Elements/movies/moviename/moviename.mkv

Are you sure about that? If you add that as a path in Kodi on your other box does that address bring up that folder?

yes it does.

000 i wrong i know i have just left out the last part of my Ip address did not want to give it away

thanks i have solved it i think. it is now just re-scanning data.

If you went the path substitution route and did it correctly then you wouldn’t be re-scanning anything as your original library would be working as it had been before you moved to MySQL. If you are going to start fresh then remove the path substitution and delete your library and start over from scratch.