Pi 2 Not Booting if USB Devices aren't Exact

My Pi 2 won’t boot OSMC when anything other than a specific USB setup is used: All 4 sockets must be populated (1 USB Flash Drive for booting, 1 External HDD which must be turned off to boot, 1 Wifi Dongle, and a powered USB Hub which must have nothing plugged in to it apart from the Pi’s power socket). If the above conditions aren’t met - for example removing the USB hub or unplugging it’s power supply and using a normal PSU for the Pi so it has a high enough current to run in a stable manner - it will refuse to boot. This, obviously, is a problem because the USB Hub is required to boot the device even when it isn’t being used for power and I can’t have it plugged in along with the Pi’s power supply, and the HDD needs to be plugged in but turned off to boot as well, so I have to unplug it from my extension lead every time I want to use the Pi. Is there any way I can fix this?! When I turn it on and any of the above conditions aren’t precisely met it comes up with a kernel panic (not syncing: VFS: Unable to mount root fs on unknown-block(8,1) and I have to shut it down and fix the peripherals that are/aren’t attached.

You ought to be able to simplify things to the extant that it doesn’t matter which sockets you use by specifying the boot filesytem by ID in /boot/cmdline.txt
Does that help enough, or do you need it spelt out?
(Hint - search the forum)



I just used the USB stick’s normal UUID in fstab instead, and left the SD card as it was and it hasn’t made a difference. Maybe the USB stick is only getting enough power from the USB hub being plugged in, and can’t work with the HDD or a keyboard also drawing power at boot? Do powered USB devices provide power to the USB controller? I’m guessing the HDD wouldn’t be able to do that because the SATA/USB connector inside will be isolated from it’s power supply.

This is why you must use PARTUUID

OSMC does not support UUID at this time, due to lacking an initramfs.


Thanks. I thought it wouldn’t make a difference. I’m guessing that’s why the SD card doesn’t have a UUID, just a PARTUUID.

Using PARTUUID also didn’t help, so it’s probably just that it doesn’t have enough power for the USB stick on 1.5A at boot without the powered USB hub attached, which I’m assuming is powering the USB controller.

Hi All, I was opening a new thread but I found this, I tried to mount the root partition, on my RPI2, from an external HD with its own power supply following this guide:


But it didn’t work, now I read I must use PARTUUID, please could someone put any explicit example how must be written the line in FSTAB and the command in the CMDLINE.TXT?

Thanks in advance.

I am sorry I did a mistake so I was not able to launch the system from an external drive :frowning:

Hi All, I did it!

Below my configuration:

root=PARTUUID=000b46b3-05 rootfstype=ext4 rootwait quiet osmcdev=rbp2 rootdelay=5

cat /etc/fstab
proc            /proc           proc    defaults          0       0
/dev/mmcblk0p1  /boot    vfat     defaults,noatime    0   0
# /dev/mmcblk0p2  /    ext4      defaults,noatime    0   0

## USB 5T Drive
/dev/disk/by-uuid/dff32edf-d65d-442c-bc07-3896f04aa6c4    /   ext4    defaults,noatime  0       1

df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/root        15G  647M   14G   5% /
devtmpfs        364M     0  364M   0% /dev
tmpfs           368M     0  368M   0% /dev/shm
tmpfs           368M  5.1M  363M   2% /run
tmpfs           5.0M     0  5.0M   0% /run/lock
tmpfs           368M     0  368M   0% /sys/fs/cgroup
/dev/mmcblk0p1  240M   17M  224M   7% /boot
/dev/sda6       4.5T   64M  4.3T   1% /media/seagate-5T
/dev/mmcblk0p2  7.0G  625M  6.0G  10% /media/2e083d11-7d54-4797-82af-206b27c0ffaf
tmpfs            74M     0   74M   0% /run/user/1000

I resolved but not using uuid or part-uuid, every time I tried to use these strings I was unable to boot from the external disk, right now it works only using /sdaX.