Pi 2 - Unable to access peripherals - OSMC Alpha 4

I have som issues regarding pi changing source when boot / reboot. I have tried adding hdmi_ignore_cec_int=1 with no luck. When I type hdmi_ignore_cec=1 nothing works at all (but thats the whole point).

So my last chance of getting this done must be through peripherals in kodi’s system meny. System -> Input devices -> Peripherals. When I try to access peripherals nothing is happening.

Can someone please tell me how to access this menu in another way or tell me if there is a bug preventing me from accessing this menu? I’m using Pi 2, Alpha 4 (latest).

1 Like

Hi @telluz, did you manage to fix this problem?
I also get an empty list on Peripherals on Pi 2 and OSMC Alpha 4.
The same TV with Pi 1 and raspbmc was working ok, and the menu was accesible.

I would recommend that you start using the RC release.

Sorry, actually, i’m on RC (OSMC 0.9.9 compiled Mar 14 2015).

Did you do a fresh install to get the RC ?

If you “upgraded” from Alpha 4 it will still say (OSMC 0.9.9) but you will not be on the RC. The only way to get to the RC is a fresh install.

1 Like

Hi @DBMandrake,
Yes, it’s a fresh install.
Note 1: My TV Remote does control OSMC, but i can’t acces Pheripherals on Input devices (to disable auto power up of tv when OSMC starts).
Note 2: The log piece “NOTICE: Register - new cec device” is not logged on every Pi restart.
This is the parts of log file that might be useful:

01:19:22 T:1957167104  NOTICE: -------------------
01:19:22 T:1957167104  NOTICE: Starting Kodi (14.1 Git:Unknown). Platform: Linux ARM (Thumb) 32-bit
01:19:23 T:1957167104  NOTICE: Register - new cec device registered on cec->RPI: CEC Adapter (2708:1001)
01:19:23 T:1875416096  NOTICE: Thread CECAdapter start, auto delete: false
01:19:23 T:1957167104  NOTICE: Config:
01:19:23 T:1957167104  NOTICE: Config:

Which skin are you using ? I’ve noticed that the Peripherals page doesn’t work on some Skins such as Black Glass Nova - this seems to be a Skin bug.

Can you try switching to a difference skin and accessing Peripherals ?

Yes, i’m using ‘eminence’, knowing this could be a skin bug, i tried several times to access ‘Peripherals’ on Confluence and OSMC skins, without results.
But i’ve just tried one more time and it works! I can acces Periherals on both Confluence and OSMC skin.
I don’t know what could be the trigger to allow me acces this menu, but yesterday i added to config.txt ‘hdmi_ignore_cec=1’ and restarted, and nothing happened so i ingored the change.
I can now see that ‘hdmi_ignore_cec=1’ has not persisted on ‘config.txt’.

Everything is working as expected now.
I could disable ‘osmc making pi the default source on start’ that was making my tv to power on every time the electric grid goes down and up.

Thank you both for taking the time to review this thread. And for this great MC.

Glad you got it working. hdmi_ignore_cec=1 completely disables CEC support on the Pi so would prevent it appearing in Peripherals as well.

The default config.txt has hdmi_ignore_cec_init=1 which is different - it just stops the Pi sending an active source message during early boot (when the rainbow screen appears) but does not prevent CEC working in Kodi.