PI 3 b osmc boot error

Hi, I’m new to this and I’ve run into an error.
Using Pi 3 model b
Elecrow 5" lcd hdmi touch screen

(Product link)

After plugging in power cable it says
“waiting for root filesystem device /deb/mmcblk0p2”
then after a minute it says

" FATAL ERROR: Could not find root filesystem device /deb/mmcblk0p2 - if this is a USB install please check the USB drive is connected.
OSMC initramf’s rescue console.
For help and support see https://osmc.tv/ "

Are you using a USB install? You need to explain a bit better what you’ve done to get to this point?

So sorry, I’m using a 16gb micro SD card. No USB install. I used the OSMC windows desktop application to create the image that’s on the SD card.

Do you have a different sdcard you can test with?

No, I don’t. But if absolutely necessary I could order another one from Amazon, I guess. It’d take a couple of days, though.

Samsung, SanDisk or OSMC brand are best

Noted.
I have a 16gb sandisk ultra

Have tried a fresh install on the SD card and booting it without the touch screen but with just normal TV connected?

You can also test your SD-card with your Windows PC, perhaps this speeds up some things. Steps I suggest

  1. Reformat your SD-card using actual “SD Memory Card Formatter”, link Downloads URL - SD Association

  2. Use the test program “H2testw” to check your SD card for any problems; the program also has an English interface, see link http://www.heise.de/download/h2testw.html

No, I haven’t. I’ll let you know the results.

Ok. I’ll get edit when I’ve done these things. Thanks everyone for the input.

Update: I tried connecting to my TV and same result. I reformated then used the SD testing software and my SD had no issues.