PI 3 SSH Issue

Hello OSMC Forums!

I searched the board but could not find a similar case.

Have a brand new PI3 with OSMC 2016.02-4, network connectivity is ok, i can ping it, sshd is running.
If i SSH to the PI i see the login Banner and enter the standard user and password osmc/osmc.

After that i see no response from the pi. No welcome Banner, no prompt… SSH Client (putty) tells no errors.
Password is correct. If i enter a wrong password, i get the “wrong password” message.
I uninstalled the SSH App and installed it again, same problem.
Tried both, WiFi and Ethernet.

Can someone help please?!

Ha Ha… got it.

It does not work if both Network Interfaces are active.

If i want to SSH to the Ethernet Interface IP - i must deactivate the WiFi Network in OSMC Settings.
If i want to SSH to the WiFi Interface IP - i must deactivate the Ethernet Network OSMC Settings.

Is this a Bug or normal at Linux?

Do I understand it correctly you have both Wireless and Ethernet activated at the same time in the same network?
If that is the case than it is not related to Linux but to TCP/IP networking in general.

Yes correct. Both where active due to testing.

Anyway, I don´t think that it is related to TCP/IP because i can reach the ssh service and see the login banner. Connection on Layer 4 is ok…

Thought that it is normal using multibel NICs in Linux world. Every Mailserver has two NICs and normaly they use SSH to manage the server…

Thanks for your reply.

I dont need both interfaces at the PI, problem is solved for me.

Well if you believe this is “normal” then I wonder why it is not working :slight_smile:
Two NIC’s in one machine being on the same subnet is calling for all kinds of trouble and breaking ethernet architecture unless you have them configured in a specific setup (e.g. loadsharing)

Stumbled into this as well. Could log into ssh tho, but some commands like top or opening files in nano or cat just ended up in nirvana.

Would be nice if one could enable both interfaces, and OSMC actually only activated one (preferably wired) at the same time. So if no ethernet is available it would still try to fall back to wireless and when ethernet was connected it would disable wifi.

You should be able to do that by adding this to /etc/connman/main.conf


1 Like

Found it in /etc/connman.prefs
And it’s working. Thank you @TheHacker66 !

I’m glad it works! :+1:t2: