Pi 3 video stuttering and freezing since upgrade


I switched from a Pi2 to a Pi3 after the OSMC update was released. Since then I have been getting random freezes when watching video streaming from my NAS. This can happen after 5 minutes or 40 minutes and sometimes restarting the video helps and other times it doesnt. I have tried underclocking the Pi to 900 arm freq, I have been monitoring temperatures and they dont go above 50 degrees and I have disabled wifi powersaving with no change. I have now ordered a 2.5a power supply and heat sink just in case! Please help. Thank you very much. http://paste.osmc.io/sorakokone


Can you confirm if the problem only affects wifi?
i.e. connect to wired ethernet or play some local (e.g. sdcard or USB stick) files.


Thank you very much for taking the time to reply. It could potentially be the internal wifi, prior to the Pi3 I was using a dongle. I may just try the dongle again once my new power supply arrives in addition to trying a usb stick. i noticed in the log there are a lot of references to fanart so I have tried to disable this and have updated my skin as well to a Jarvis version. There is a timestamp in the log that roughly matches the time the video started stuttering:

19:40:22 2298.490479 T:1374135280 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer

Does this have relevance to the issue? Does it point to a network issue? Than you again for your help.

I’ve had the same problem. I upgraded from an RPi 2 to an RPi 3. I’m using the built in WiFi to view movies from an NFS share on a Linux box and have had big hassles with the video stopping while I’m watching it. Fiddling with the cache settings hasn’t helped.

I bought the license keys for the hardware MPEG2 and WVC1 decoders. Since installing the license keys, I haven’t seen it hiccup once - even playing movies that were previously un-watchable.

Can you elaborate?
You bought those licenses for Kodi/OSMC and since then you don’t have hickups while watching over WIFI?

Correct. It’s been fine since I bought the hardware decoder license keys. I think that recent updates to OSMC have helped as well.

For the record, I’m using the RPi 3’s built in WiFi, but it’s located fairly close to the wireless access point.

Same problem here but my issue is a straight Pi3 monthly upgrade (June to July) giving me grief.

In my setup I run a mythtv backend tv server which also serves as a NAS for all my audio/video. My frontends are a regular HTPC in addition to a Pi1, Pi2 and a Pi3.

All frontends are connected via ethernet except for the Pi3 which I access via the onboard WiFi.

Prior to the July update the video for both MythTV and regular video files worked flawlessly however since the update it buffers and stutters terribly.

In fact, checking the on-screen hardware throughput/load while video is playing regularly shows the “error %” skyrocketing which in turn causes the system to buffer.

I’ve not had a chance to try connecting the Pi3 via ethernet but given I’ve made no other changes to any of my setup I can only guess something has gone awry in the July update for WiFi.

I should also point out that I have purchased and currently use the separate hardware decoder licences and have the Pi3 running on the recommended power supply.

Suggest you check your wifi connection with iperf and wavemon


iwconfig; iperf and wavemon all tell me the same thing…there is something apparently wrong with the Transmit (Tx) side of things as per the output below. Using iwconfig et al, I see the “Tx excessive retries” value rocket upwards to coincide with the buffering issue.

No other apparent issues with WiFi devices in my house and never saw this problem before the July update and the access point is only about 3 metres away (albeit through a wall).

Your thoughts guys?

      Bit Rate=72.2 Mb/s   Tx-Power=31 dBm
      Retry short limit:7   RTS thr:off   Fragment thr:off
      Power Management:off
      Link Quality=48/70  Signal level=-62 dBm
      Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
      Tx excessive retries:5175  Invalid misc:0   Missed beacon:0

Have you seen these yet?


No. I haven’t. But MythTV doesn’t use SMB to my knowledge. It uses it’s own proprietary format.

I’ll have a read through the thread and see if anything may be able to assist.

Thanks anyway.