Pi 3 WiFi unstable


I keep loosing wireless connection to OSMC on my Pi 3… Sometimes, when I try to access the device with SSH or SFTP, the connection just times out. This usually happens after longer inactivity.

I’m running latest OSMC release, installed using March update. I’m using 2.5A power supply shipped with Pi 3. There’s no LAN connection, WiFi running via onboard module.

I have a feeling it might be related to wifi power management settings - iwconfig tells me those are ON. Has anyone experienced similar issues?


Ftp problem


I have buy a Pi3 yesterday, and I also have this error.
The wifi is up and down.

Neither Kore (remote controller app) and SSH can’t acces to the Pi. :frowning:


Can you ssh in and run

and see if that makes it more stable. It disables power management of wireless.


I have the same problem, it just keeps dropping the SSH connection every 2-5 min.

packet_write_wait: Connection to Broken pipe

But I can then walk over and do a simple ping test and confirm that it’s still online, but can’t establish a connection SSH connection still won’t respond.

I have now run the cmd that you suggested and will get back to you with an update.


Seems to work. thx


Just in case, I have added the following two lines to ‘/etc/rc.local’ so it keeps the power off settings after a reboot.

sleep 10
iwconfig wlan0 power off


I’ll sort this out in a future update


Boosting NFS speed

Disabling WiFi power management settings did the trick - I can access OSMC anytime and immediately via SSH or SFTP.

Also, added this line: sudo iwconfig wlan0 power off to /etc/rc.local - to keep power management off after reboot.



My OSMC has no iwconfig did you install it?


That’s quite strange. What does dpkg -l | grep wireless gives you?



ii wireless-firmware-osmc 1.1.0 all Wireless firmware (proprietary) for OSMC


It is not installed by default in OSMC. You need to install the wireless-tools package.


Interesting, I can not recall that I installed it (as I only have wired connection) and I have the wireless-tools installed. Maybe installed it before to test something for the forum.

@MarkusLange sudo apt-get install wireless-tools and you are done


Sleepwalker installs :grinning:


confirm - I had to install wireless-tools package to get iwconfig.


Hi Guys, pi 3 wifi even with power management to off seems to not perform ok at all, it’s not possible to watch a descent size mkv from NAS with onboard wifi…

Any way to disable the onboard so we can use a usb wifi dongle??
(just adding a dongle seems to not work, it keeps using the bad onboard wifi)



Thank you so much that hint helped me out

I created /etc/modprobe.d/raspi-blacklist.conf and added into it:
blacklist brcmfmac
blacklist brcmutil

saved it and rebooted

After this it accepted my usb dongle and the world is again a better place… :slight_smile:


Should maybe an option inside the OSMC-addons to do that


Yes, that’s not a bad idea.