Pi 3B or 3B+ / Amp2 / pi official 7‘‘touch display


#1

Hi everybody

OSMC I have a problem…

I have a raspberry pi model 3B and a model 3B+. I want to combine one of them with the hifiberry amp2 and the pi official 7’’ touch display. The combination is powered via Amp2 with the recommended power supply (Mean Well: GST60A18-P1J) which works fine.

On the SD-Card I installed OSMC (Linux osmc 4.14.78-2-osmc) where the media center Kodi 17.6 is running.

Pi 3B/3B+ works fine, as well as the display and amp2 but my problem is the touch function of the display:

The touch function doesn’t work or works intermittently and or delayed - but most of the time it doesn’t work, so at the moment it is not usable for navigation in Kodi. But when I detach amp2 and run the screen with pi only the touch function works fine almost as good as on a smart phone. This problem I have with both models of pi (3B and 3B+).

In some posts I read that the problem might be because of the I2C-Bus which is needed and used by the amp2 and the touch function of the display. Without amp2 I don’t need to connect the additional jumper for SDA and SCL everything works fine. When amp2 is attached, no matter if SDA/SCL is connected or not, either it doesn’t work, or it works very poor as explained above.

So, please can you help me with this issue? Is this hardware combination a total no go combination or is it only a configuration problem?

The same question I already asked Hifiberry and got the answer:

“the display uses a separate I2C bus directly connected (not via the GPIO that the Amp2 is connected to). We know about a lot of users that use the display without problems. Unfortunately I can’t say what might be causing the problem in your installation. You might try other Kodi-based systems e.g. LibreElec.”

But I still don’t know if it is a system or config based problem. Could you please help me?

I tried to give you as much information as possible about my hardware/software setup. If you need more information just go ahead and ask for it. Thanx in advance for helping me!

Best regards


#2

I don’t own such display but reading

only the DSI ribbon cable is required.

Only the old Pi 1A and Pi 1B need an entry in the /boot/config.txt. I think, you’ve setup this in a correct way?


#3

Hi JimKnopf,

the hardware setup is correct! Only the DSI ribbon cable is connected. Tried with the jumper for SDA/SCL as well only becauese I read in some post that for some pi models it is needed. It was a reaction of desperation only.

Now imagine there is a connection via ribbon cable only. When I start without the hifiberry amp2 touch function works perfect. When I attach the hifiberry amp2 the touch function is poor.

The only entry in /boot/config.txt I have currently is:

ignore_lcd=0.

But even with this it doesn’t matter if this entry is in the config or not. It is the same behaviour with and without!


#4

Hi everybody,

anyone an idea how to solve this problem? Or any hint which direction I should look at?

Thanx in advance.

Best regards


#5

Hi OSMC-Team,

do you have any idea?

Thanx


#6

Could be a shielding issue.


#7

Hi Sam,

what do you mean with shielding issue?

Regards


#8

Hi,

just an update - I have the same problem not only with OSMC as well the problem is the same in rasbian. Rasbian is installed on a separate SD-Card updated and upgraded, here the information of rasbian version (Linux raspberrypi 4.14.79-v7+ #1159 SMP Sun Nov 4 17:50:20 GMT 2018 armv7l GNU/Linux).

The problem is identical to that I explained above. Touch function of the display works perfect without Hifiberry amp2.
As soon as amp2 is attached everything works (sound via amp2 as well) still fine except the touch function, either it is very poor or not existing! It doesn’t matter if I use pi model 3B or 3B+, same behaviour on both pi models.

Any ideas!? I know from other forums that this combination of hardware works fine!


#9

Hi,

I would recommend trying a new ribbon if possible.
I suspect your issue is hardware, rather than software related.

Sam


#10

Hi,

well the ribbon cable that I am using is the original one that is delivered with the screen and there is no problem when the amp2 is not attached, so I would say ribbon cable is ok, but the devil lies in the details, nevertheless I will get a new ribbon and try out!

Regards


#11

For a quick test go to your kitchen, catch some aluminium foil and wrap the cable …


#12

Hi,

ribbon cable is wraped but no change!

But I have some new discovery:

When I power the touchscreen with a separat 5V-2.5A power supply the touch function is really much better, though not as good as when the amp2 is not attached but really it woks much better. Here is the new hardware setup:

  • Powering pi and amp2 with “Mean Well: GST60A18-P1J” via map2
  • Powering pi original 7’’ touch screen directly with a power supply 5V - 2,5A
  • No connection between screen to amp2 for screen powering via 5V pin

This was the setup before:

  • Amp2 is attached to the pi via 40 pin socket
  • Touchscreen is connected via ribbon cable to the pi DSI port
  • Touchscreen is connected via jumper cables to amp2 5V pin and GND pin for power supply (changed, see above)
  • No connection to the SCL/SDA pins of GPIO!
  • All are powered via amp2 with the Meanwell power supply

ok, unfortunately I don’t have a multimeter but as soon as I get one I will check the power supply at 5V pin at amp2. As well I will check the power supply when the jumper cable are connected to amp2 5V pin, if there is any voltage drop via jumper cable. I am expecting here a constant supply of 5V.

Did anyone made similar experience?

In the docs for the touchscreen I read something about the I2C-Bus:
https://www.raspberrypi.org/documentation/hardware/display/

NB: With the display connected to the GPIO I2C pins, the GPU will assume control of the respective I2C bus. The host operating system should not access this I2C bus, as simultaneous use of the bus by both the GPU and Linux will result in sporadic crashes.

In my config Linux access is commented out - so only GPU I2C access is ensured:

#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

Or should I change something here?

Thanx and regards


#13

Hi everybody,

latest news from my issue with the touchscreen: It is NOT A SOFTWARE ISSUE!!!

This post is a bit long and a kind of a report – be patient and read it :wink:.

It is somehow a hardware issue which I can’t explain at the moment. As well it is to mention that I have found the solution for me a little bit coincidently – but still have some question marks in my head!

What I have done since my last post:

I got a multimeter from a friend and measured the touchscreen support directly at the 5V pin to the GND of amp2. (And promptly I destroyed my new – even not one-month old pi 3b+ while measuring because I slipped with the tip of the contact and build a bridge between the 5V and 3V pin, bloody hell :frowning: and all this because a very trivial issue but luckily only the pi is destroyed other components are still fine).

Well before that mishap I measured about 5.06V at the pin. Then I had to change the pi and installed my pi 3b and measured again – very carefully :wink: – and measured again 5.06V, so power supply at the pin is ok. Next step – I connected the jumper cable for the touchscreen support to the 5V and GND pins on amp2 and measured at the end of the cables which will be connected to the display board – here as well 5.06V, so still enough power there. During all this the screen faced down to the table to get good access to the pins. Then I took all the construct with display, pi and amp2 in my hand – this is the coincidently moment – and tried out to navigate with the touch function and Look! It works perfect even the amp2 was attached! Then I played some music and it worked as well and I could even use the touch function at the same time while the music was playing without any problems.

Maybe one more thing that everybody should know – I assembled some brackets to the chassis of the display at the back to put it straight upward for a comfort use and look. But unfortunately, the free space between the construct and table is a little bit small and at the same time the power supply connector of amp2 faces towards the table and the barrel-connector of the power supply is a bit long, so when it is connected to amp2 the space is even smaller – too small to put it on the bracket’s feet. Therefore, I positioned the whole construct somehow in the box of the display with the foam inside for having as less bending on the supply cable as possible and this is one of the positions when the touch doesn’t work.

Nevertheless, I measured the 5V pin in this position as well and power supply was ok – 5.06V but touch function poor, so it can’t be a power supply issue. With this finding I took the construct in the hand again, hold it at the bracket and bended the power supply in many directions – small bends, big bends of the cable, jiggled and shifted directly the barrel-connector – and tried at the same time to navigate with the touch and there was no problem with the touch function, it worked perfectly. Then I tried jacking up the brackets at its feet to get more space between the construct and the table, so that the cable can hang little bit more free and straight. Subsequently I put the construction on the table and not in the box again. Result – bad touch reaction. In this position I measured the power again, still 5.06V. …???.. What is the problem? I don’t know! Doesn’t matter in which position and constellation only the cables and power supply are connected in a right way and firmly and there is no other contact of the components with anything else so that we can exclude any possible short circuits or something similar.

Someone told me to shield the ribbon cable between screen board and pi by wrapping the ribbon cable with some aluminium foil, which I did already before (and which didn’t help). Based on that ideas I put the supply cable and loudspeaker cable and with other parts and cables closer together to see if there are any EMC issues – still good touch reaction when I hold it in my hand, so that can’t be the problem either!

When there is the problem with the bad or no touch reaction – sometimes while trying the mouse arrow appears in the upper left corner of the screen but doesn’t move. So, I guess sometimes the touch reaction is been gathered by the system but not used.

But here is another phenomenon – physically I keep the construct in that position in my hand in which it works perfectly as described above and don’t change. Then I change only the config.txt to rotate the display 180° and reboot. After reboot I see everything upside-down in the display and try to navigate with touch – nothing happens, so no touch function even the supply cable is in that position in that it worked before rotating the display via change of config!

So, hopefully now everybody can understand why I still have question marks in my head and can’t explain the behaviour! But fortunately, and/or hopefully I found now my solution – after I will be done all my implementation – I would install everything in that way as I would hold it in my hand and hope that it works!

But this is pitiful and pelting and keeps still some doubts that it will work in the end when everything is ready, and I put it in a nice box. I would like to exclude the doubts and be sure that it will work fine when I am ready with everything!

So, if anyone have an idea what the problem might cause – go ahead and tell me! :wink:

Best regards

PS: If someone wants, I could make some Fotos of the whole construct and post it here!