PI 3B - OSMC - HDMI-CEC problem

Hi there, looked at the category but didn’t find anything similar to my problem.
My system:
Pi 3 B
OSMC latest version )OSMC_TGT_rbp2_20201227)
TV LG 43UM7300 Magic Control WebOS 5.0.x

After installing OSMC on SD and run on PI, the OSMC main menu shows up but no reaction from TV remote control. Yes, CEC (Simplelink LG) is activated. Can’t do anything on TV.
SSH& Samba to have a look at the files. Find out:

  1. no remote.xml in folder keymaps.
  2. in folder peripheral_data/rpi_2708_1001_CEC_Adapter.xml find this entry:
    setting id=“cec_hdmi_port” value="1"

My guess this is addressed to the wrong HDMI port on my TV, because on TV HDMI #1 is connected to Bell Express, and PI-OSMC is connected to HDMI #2.

So edit this entry to setting id=“cec_hdmi_port” value="2" and restart OSMC with:
sudo systemctl stop mediacenter
sudo systemctl start mediacenter

Still the remote not working. And when I check the cec_hdmi_port" value= setting in peripheral_data/rpi_2708_1001_CEC_Adapter.xml, the value is reset to 1 again.

I’m not sure what the CEC setting is on PI (enabled or disabled), and have no idea how to do/check via ssh.

Any ideas much appreciated, because now fighting with this problem for days. And actually, it appeared the first time after an automatic update from OSMC_TGT_rbp2_20201019.img, before worked fine.
thx, and please excuse my German-English

Power off both the Pi and the TV at the mains (unplug from power) for a couple of minutes.
If problem remains upload debug enabled logs

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Your looking in your user profile. remote.xml is in the system side of things and is also not the keymap that CEC uses. Regardless, whatever your issue, it is not keymap related.

That is what it should be. There is nothing in that file you need to edit outside of the the GUI.

The CEC settings are found in settings>system>input>peripherals>CEC adapter

As long as “enable” is set there (may require a reboot if it was disabled) it should accept CEC input and at minimum the direction controls will be correctly mapped. What I would check is your TV settings for that magic remote. I’ve seen people not realize that when they ran the device wizard it configured their remote to use IR which stops the TV from forwarding CEC remote commands for that source.

Hi thank you guys, I got it solved.
1: Power off all devices didn’t help. Still no remote reaction.
2. Then connected a USB mouse and keyboard to my PI, and after the reboot was able to browse with mouse and keyboard. Find out in OSMC CEC was disabled, so changed that, chose OSMC remote, reboot and reconnect to TV, and is working now. Happy.
Good and safe 2021 to you…Thx

It was disabled in the system settings I pointed to above or are you saying that you went to the My OSMC addon and in the remotes section enabled osmc-remote-lircd? If it is the latter then that is not CEC and the issue was your magic remote got configured for IR.

Hi DarwinDesign, yes CEC was disabled in
OSMC->System->Settings->Input->Peripherals->CEC Adapter->disabled.

And this was after the update from OSMC_TGT_rbp2_20201019 to OSMC_TGT_rbp2_20201227.
So after the update, there was for me no chance to change the settings with the TV remote. Just after rebooting the PI with USB Mouse and Keyboard, I was able to navigate through the OSMC menu and change the settings to CEC Adapter = enabled. and yes as you mentioned, in MyOSMC assigned to osmc-remote-lircd.

Also deleted all HDMI connections on my TV and re-connected my Sat-receiver, Pi OSMC, and Western Digital.

So everything runs well now.


Beside this issue, maybe just another short question:
Running Kodi on the Pi, is it possible run Kodi /Jellyfin-client and the Jellyfin-server on the same device? THX

I would assume yes. I don’t know what kind of performance and memory issues you would run into, but I’m pretty sure I remember seeing at least a couple people running the server on OSMC. I’m not sure how much help you would find on this forum though. That particular software doesn’t really get mentioned much here and I think only one of the moderators have even played with it. I don’t remember which one.