Pi 4. Finishes "Installing files" screen, then blank

Hi there,
I’m trying to install OSMC on a Raspberry Pi 4 Model B. I put the disk image on to an SD. When it boots up it does the normal beginning stuff of showing the OSMC logo and shows the Installing files progress bar. Then it briefly flashes a terminal screen about loading boot image. And then nothing. My TV goes back to saying there is no input signal.

Has anyone else had this issue or have any ideas on how to troubleshoot this? I’ve tried it on 2 TVs and reinstalled the disk image a few times.


Does any of the TVs have a native resolution of 1980x1080 or higher? I had a similar issue with an old “HD ready” TV with a resolution of 1366x768 where I had to force an HDMI output of 720p in OSMC/Kodi in order to get beyond the splash screen.

Both TVs I tried were 4K resolution. Both also work well with OSMC running on a Pi 3.

I’m experiencing a similar issue but on an Rpi3. Tested with multiple sd cards and multiple installation mediums (disk image install via a flash utility on linux, and the Windows OSMC install tool).