Pi Config no work


#1

I have Raspberrypi 2 with image OSMC 2015-12-4 after update manual MyOsmc section -> Pi Config no work … Bug?

Best regards. Thamks.


#2

Hi reload the image from scratch. I had the same problem after doing updates.


#3

Will need to see a log


#4

Can you first do another manual update to ensure that all updates proceed and if the issue remains provide some logs.

OSMC has the easiest method of providing logs of any Kodi distribution we know of. We show you what to do here http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ Please follow those instructions because without the information they provide, we really can’t do anything to help you.


#5

Hi @Sam attached log file

File log

Thanks!


#6

Please upload it on a proper Pastebin site.


#7

This link http://pastebin.com/rWGdHzeH


#8
"/usr/share/kodi/addons/script.module.osmcsetting.pi/resources/osmc/OSMCSetting.py",
 line 208, in run                                                extracted_settings = parser.config_to_kodi(parser.MASTER_SETTINGS, config)                                              File 
"/usr/share/kodi/addons/script.module.osmcsetting.pi/resources/lib/OSMC_REparser.py",
 line 49, in config_to_kodi                                                value = general_config_get(config, **protocols)                                              File 
"/usr/share/kodi/addons/script.module.osmcsetting.pi/resources/lib/OSMC_REparser.py",
 line 91, in general_config_get                                                result = config_validation(raw_value.group(1))                                              File 
"/usr/share/kodi/addons/script.module.osmcsetting.pi/resources/lib/OSMC_REparser.py",
 line 317, in gpio_updown_validation                                                return str(permitted.index(config_value) + 1)                                            ValueError: '' is not in list01:05:37  43.605068 T:1662735392   ERROR: CCurlFile::FillBuffer - ```

One for @Karnage

#9

Thanks @Sam I come back image OSMC 2015-11-1 expect solved this bug on Kodi.

Best Regards Thomas


#10

Found the issue, it will be fixed in the next update.

To get the fix now go to MyOSMC, Updates, Manual Controls, Apply HotFix and enter this code: [deprecated]

After that, reboot, and the problem should be solved.

Give it a try and post the logs if it fail