Pi keeps crashing

Raspberry Pi 4, connected to Synology NAS. Click on show to start, momentary load symbol, then crash. TV and Movies that have been played OK previously now don’t. Not all, some work fine. So far I have updated two of my 4 drives, older ones out, new WD red in. Put in a new power supply for the PI - previous one had an push button on/off switch, and Pi kept showing low volts, having changed the P/S I think it was the switch.

I’ve cleaned the library, removed and replaced some of the video, sometimes that worked or not.

So any answers or ideas, also where to find the logs so i can try and sort this out? Thanks

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thanks, that is the sort of info I needed. I’ll get onto it.

Sorry, it has taken me a while. Death in the family took me away from home.


I picked a particular TV episode, but it is one of many and also movies. Most work OK but a lot don’t with no particular pattern. Hope you can pick the bones out the problem. Everything worked great until about two months ago. I have made no changes to the Pi except a new PS to resolve a low current warning, which I believe was due to an inline ON/OFF switch on old PS.

Thanks for looking.

Sorry to hear this.

The problem is that you have the staging repository of OSMC activated. This has a newer kernel which will only be compatible with Kodi v20. You might have activated this to test an improvement or fix in the past.

Your options are:

  1. Reinstall OSMC, and it will work as expected.
  2. I can give you instructions on how to reinstall the current stable kernel, but you’ll need to know how to use SSH.
  3. You wait a little bit until we release Kodi v20 in an official capacity. You will then get an update prompt and things will work as expected

Apologies for the inconvenience



Thanks Sam. No inconvenience, that’s life. At least I now know what the issue is.

Any guesstimate on the v20 release timetable?

I’ll start some test builds next week with any luck.